summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormauriciodelima212023-09-03 19:45:18 -0300
committermauriciodelima212023-09-03 19:45:18 -0300
commit67eac07114afe8daf1b8b7284f41b917174a7ec8 (patch)
treebffd4606e40e86b047681c5f135d918bfe2f0a5a
downloadaur-67eac07114afe8daf1b8b7284f41b917174a7ec8.tar.gz
commit initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--uaiso-keyring.install26
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0eb1653b46bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = uaiso-keyring
+ pkgdesc = Package Keyring for UaiSO
+ pkgver = 230903
+ pkgrel = 1944
+ url = https://gitlab.com/uaiso/orion
+ install = uaiso-keyring.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = uaiso-keyring
+ options = !strip
+ options = !emptydirs
+ source = uaiso-keyring::git+https://gitlab.com/uaiso/orion/uaiso-keyring
+ sha256sums = SKIP
+
+pkgname = uaiso-keyring
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a6ca6059de3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mauricio de Lima <emauricio@uaiso.org>
+pkgname=uaiso-keyring
+pkgver=$(date "+%y%m%d")
+pkgrel=$(date "+%H%M")
+pkgdesc="Package Keyring for UaiSO"
+arch=('any')
+url="https://gitlab.com/uaiso/orion"
+license=('GPL3')
+makedepends=('git')
+provides=("${pkgname}")
+options=(!strip !emptydirs)
+source=(${pkgname}::"git+${url}/${pkgname}")
+sha256sums=('SKIP')
+
+if [ -e "${pkgname}.install" ];then
+ install=${pkgname}.install
+fi
+
+package() {
+
+ InternalDir="${srcdir}/${pkgname}"
+
+ # Copy files
+ if [ -d "${InternalDir}/usr" ]; then
+ cp -r "${InternalDir}/usr" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/etc" ]; then
+ cp -r "${InternalDir}/etc" "${pkgdir}/"
+ fi
+
+ if [ -d "${InternalDir}/opt" ]; then
+ cp -r "${InternalDir}/opt" "${pkgdir}/"
+ fi
+}
+
+
diff --git a/uaiso-keyring.install b/uaiso-keyring.install
new file mode 100644
index 000000000000..3ffc06c5bd4c
--- /dev/null
+++ b/uaiso-keyring.install
@@ -0,0 +1,26 @@
+# Maintainer: MaurĂ­cio de Lima <mauricio@uaiso.org>
+
+msg() {
+ local ALL_OFF="\e[1;0m"
+ local BOLD="\e[1;1m"
+ local GREEN="${BOLD}\e[1;32m"
+
+ local MESSAGE=$1
+ shift 1
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${MESSAGE}${ALL_OFF}\n" "$@" >&2
+}
+
+post_upgrade() {
+ if usr/bin/pacman-key -l >/dev/null 2>&1; then
+ usr/bin/pacman-key --populate uaiso
+ else
+ pacman-key --init
+ pacman-key --populate uaiso
+ fi
+}
+
+post_install() {
+ if [ -x usr/bin/pacman-key ]; then
+ post_upgrade
+ fi
+}