summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Melletti2016-02-18 21:49:58 +0100
committerMarco Melletti2016-02-18 21:49:58 +0100
commita95f6303115892308dcd22f81aaf01606078adbe (patch)
treeb3a9bafddf3adf974ada8a871f6ae5e5b9dddec9
downloadaur-a95f6303115892308dcd22f81aaf01606078adbe.tar.gz
v1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd854660828
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.0.0
+# Thu Feb 18 20:49:16 UTC 2016
+pkgbase = uarm-git
+ pkgdesc = arm7tdmi based computer emulator with debugging tools
+ pkgver = v0.5.3.r26.3600cec
+ pkgrel = 1
+ url = http://mellotanica.github.io/uARM/
+ arch = any
+ license = GPL
+ makedepends = git
+ backup = etc/default/uarm
+ source = git+https://github.com/mellotanica/uARM.git#branch=master
+ md5sums = SKIP
+
+pkgname = uarm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0a867ba35c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Marco Melletti <melletti.marco@gmail.com>
+pkgname=uarm-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=v0.5.3.r26.3600cec
+pkgrel=1
+pkgdesc="arm7tdmi based computer emulator with debugging tools"
+arch=('any')
+url="http://mellotanica.github.io/uARM/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git')
+replaces=()
+backup=('etc/default/uarm')
+options=()
+install=
+source=('git+https://github.com/mellotanica/uARM.git#branch=master')
+noextract=()
+md5sums=('SKIP')
+
+_gitdir='uARM'
+
+pkgver() {
+ cd "$_gitdir"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$_gitdir"
+
+ ./configure
+
+ qmake-qt5 elf2uarm.pro
+ make
+ qmake-qt5 mkdev.pro
+ make
+ qmake-qt5 qarm.pro
+ make
+
+ ./compile
+}
+
+package() {
+ cd "$_gitdir"
+ ./install.sh -b "$pkgdir"
+}