aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteadfasterX2019-01-04 15:54:02 +0100
committersteadfasterX2019-01-04 15:54:02 +0100
commit4b6952465031570d90a979d8de6dc4b3e041f985 (patch)
tree114ccd18a1f1f44df587ede462085b0a9767ae32
parent3e291bbc4d5d8236020504e8ba6606730d09439b (diff)
downloadaur-4b6952465031570d90a979d8de6dc4b3e041f985.tar.gz
new: automate account expiration etc
- fix: pkgdesc - update SRCINFO - removed obsolete config howto this will be handled now automatically
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--README.md4
-rw-r--r--uau.install4
4 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b465c83a3e16..6d5da2a60de9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uau
- pkgdesc = A little helper for installing Arch upgrades scheduled, respecting the recommended upgrade checks and doing all this non-interactively
+ pkgdesc = unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance).
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/steadfasterX/arch_uau
install = uau.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index dd761e9fdb90..b407812a28ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: steadfasterX <steadfasterX [at] gmail -dot- com>
pkgname=uau
pkgver=1.1.0
-pkgrel=1
-pkgdesc="A little helper for installing Arch upgrades scheduled, respecting the recommended upgrade checks and doing all this non-interactively"
+pkgrel=3
+pkgdesc="unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance)."
arch=('any')
url="https://github.com/steadfasterX/arch_uau"
license=('LGPL3')
diff --git a/README.md b/README.md
index f3e74716a917..181e988a6829 100644
--- a/README.md
+++ b/README.md
@@ -28,10 +28,6 @@ I use and have tested only sstmp but every sendmail-like `mail` cmd will do.
#### Configure
-Set the expiry, inactive etc to never:
-
-`chage -E -1 -I -1 -m -1 -M -1 archupdater`
-
*/etc/unattended-arch-upgrade.conf*
All options are well documented in that conf file. Just adjust it to your needs.
diff --git a/uau.install b/uau.install
index 7b4f73f742d9..3fd20a10d321 100644
--- a/uau.install
+++ b/uau.install
@@ -2,7 +2,9 @@
post_install() {
. /etc/unattended-arch-upgrade.conf
- TODAY=$(date +%F); useradd $UPDATEUSER -G systemd-journal --expiredate $TODAY -f -1 -m
+ useradd $UPDATEUSER -G systemd-journal -m
+ # no account expiry, never set to inactive, no password expiry
+ chage -E -1 -I -1 -m -1 -M -1 $UPDATEUSER
# install archnews and ensure it is a supported version
mkdir $ANEWSDIR