aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteadfasterX2021-02-19 18:42:32 +0100
committersteadfasterX2021-03-18 17:23:25 +0100
commit6703d65ea13e6f7d79e5a3f2057feb57a6d959b4 (patch)
tree008897b9484f343f7866304b02e4fcf9eaf43899
parent4b6952465031570d90a979d8de6dc4b3e041f985 (diff)
downloadaur-6703d65ea13e6f7d79e5a3f2057feb57a6d959b4.tar.gz
bumped to v2.0.0, several fixes
fix: added post_upgrade section fix: permissions for confs + cron files new: remove checkupdates+aur dependency fix: gitignore new: added trizen as optdep
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--uau.install12
4 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d5da2a60de9..b43d19649c49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = uau
pkgdesc = unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance).
- pkgver = 1.1.0
- pkgrel = 3
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/steadfasterX/arch_uau
install = uau.install
arch = any
license = LGPL3
makedepends = git
depends = aur-comment-fetcher-git
- depends = checkupdates+aur
+ depends = archnews2
depends = sudo
depends = pacman
depends = python3-memoizedb
optdepends = ssmtp: to provide the sendmail like mail command
+ optdepends = trizen
backup = etc/unattended-arch-upgrade.conf
backup = etc/unattended-arch-upgrade.ignore
- source = https://github.com/steadfasterX/arch_uau/archive/v1.1.0.tar.gz
+ source = https://github.com/steadfasterX/arch_uau/archive/v2.0.0.tar.gz
md5sums = SKIP
pkgname = uau
diff --git a/.gitignore b/.gitignore
index 82f4af9beb14..ed47f3cd9aa4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
pkg/*
src/*
*.swp
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index b407812a28ed..f84fd8aa58c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: steadfasterX <steadfasterX [at] gmail -dot- com>
pkgname=uau
-pkgver=1.1.0
-pkgrel=3
+pkgver=2.0.0
+pkgrel=1
pkgdesc="unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance)."
arch=('any')
url="https://github.com/steadfasterX/arch_uau"
license=('LGPL3')
-depends=('aur-comment-fetcher-git' 'checkupdates+aur' 'sudo' 'pacman' 'python3-memoizedb')
+depends=('aur-comment-fetcher-git' 'archnews2' 'sudo' 'pacman' 'python3-memoizedb')
makedepends=('git')
-optdepends=('ssmtp: to provide the sendmail like mail command')
+optdepends=('ssmtp: to provide the sendmail like mail command' 'trizen')
backup=('etc/unattended-arch-upgrade.conf' 'etc/unattended-arch-upgrade.ignore')
source=("https://github.com/steadfasterX/arch_$pkgname/archive/v$pkgver.tar.gz")
md5sums=('SKIP')
@@ -31,11 +31,11 @@ package() {
install -d -m 0750 $pkgdir/${SUDOERS}
install -o ${USER} -g ${GROUP} -m 0700 conf/uau_sudo $pkgdir/${SUDOERS}/uau_sudo
- install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.conf $pkgdir/etc/unattended-arch-upgrade.conf
- install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.ignore $pkgdir/etc/unattended-arch-upgrade.ignore
+ install -o ${USER} -g ${GROUP} -m 0644 conf/unattended-arch-upgrade.conf $pkgdir/etc/unattended-arch-upgrade.conf
+ install -o ${USER} -g ${GROUP} -m 0644 conf/unattended-arch-upgrade.ignore $pkgdir/etc/unattended-arch-upgrade.ignore
install -o ${USER} -g ${GROUP} -m 0755 bin/* $pkgdir/${BINFIX}/
ln -sfv uau $pkgdir/${BINFIX}/unattended-upgrade
- install -o ${USER} -g ${GROUP} -m 0755 conf/archnews_cron $pkgdir/etc/cron.d/archnews
+ install -o ${USER} -g ${GROUP} -m 0644 conf/archnews_cron $pkgdir/etc/cron.d/archnews
install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.service $pkgdir/${SYSD}/unattended-arch-upgrade.service
install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.timer $pkgdir/${SYSD}/unattended-arch-upgrade.timer
@@ -44,6 +44,5 @@ package() {
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
install -D -m644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
}
diff --git a/uau.install b/uau.install
index 3fd20a10d321..c73ec6f405cd 100644
--- a/uau.install
+++ b/uau.install
@@ -1,4 +1,3 @@
-
post_install() {
. /etc/unattended-arch-upgrade.conf
@@ -6,15 +5,10 @@ post_install() {
# no account expiry, never set to inactive, no password expiry
chage -E -1 -I -1 -m -1 -M -1 $UPDATEUSER
- # install archnews and ensure it is a supported version
- mkdir $ANEWSDIR
- git clone $GITANEWS $ANEWSDIR
- cd $ANEWSDIR
- git checkout $ANEWREL
-
systemctl enable unattended-arch-upgrade.timer
systemctl start unattended-arch-upgrade.timer
systemctl list-timers unattended-arch-upgrade.timer
+ systemctl daemon-reload
sed -i '/\[options\]/a Include=/etc/unattended-arch-upgrade.ignore' $PACCONF
@@ -24,6 +18,10 @@ post_install() {
chmod 644 /etc/cron.d/archnews
}
+post_upgrade(){
+ systemctl daemon-reload
+}
+
pre_remove() {
. /etc/unattended-arch-upgrade.conf