summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhys Perry2023-11-22 10:17:29 +0000
committerRhys Perry2023-11-22 10:17:29 +0000
commit72535d42faf1620173ef2526d1528bbc52bbf740 (patch)
tree2bb7fccd7f984acc7ff491d3b479220a8e043c28
parentbfa556461b9a93f9b44d4a9cfc10abbae5769721 (diff)
downloadaur-72535d42faf1620173ef2526d1528bbc52bbf740.tar.gz
Fix ubertooth-btbr
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1fb112a48ec..324c4656050a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = ubertooth-git
pkgdesc = open source wireless development platform suitable for Bluetooth experimentation
pkgver = 2020.12.R1.r33.ge0fd34d
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/greatscottgadgets/ubertooth
arch = x86_64
arch = i686
license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = python-setuptools
depends = libbtbb-git
depends = libusb
depends = libpcap
depends = python
+ depends = python-libusb1
source = git+https://github.com/greatscottgadgets/ubertooth/
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d07f694b7af4..ae415ff373aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
+# Maintainer: Rhys Perry <rhysperry111 AT gmail.com>
# Contributor: Lex Black <autumn-wind@web.de>
_gitname=ubertooth
pkgname=ubertooth-git
pkgver=2020.12.R1.r33.ge0fd34d
-pkgrel=1
+pkgrel=2
pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth"
arch=('x86_64' 'i686')
license=('GPL2')
-depends=('libbtbb-git' 'libusb' 'libpcap' 'python')
-makedepends=('git' 'cmake')
+depends=('libbtbb-git' 'libusb' 'libpcap' 'python' 'python-libusb1')
+makedepends=('git' 'cmake' 'python-setuptools')
source=(git+https://github.com/greatscottgadgets/ubertooth/)
md5sums=('SKIP')
@@ -25,9 +26,15 @@ build() {
cd build
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
make
+
+ cd ../python/ubtbr/
+ python setup.py build
}
package() {
cd "$_gitname/host/build/"
make install
+
+ cd ../python/ubtbr/
+ python setup.py install --root="$pkgdir"
}