summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-07-06 22:56:25 +0200
committerNarrat2023-07-06 22:56:25 +0200
commitbfa556461b9a93f9b44d4a9cfc10abbae5769721 (patch)
treec10e8b870f4370e8b5cdd0fdce0e44e8d42288bd
parentde72ed993cf8db407d8343b5cf6611c065f791e3 (diff)
downloadaur-bfa556461b9a93f9b44d4a9cfc10abbae5769721.tar.gz
ubertooth-git: add missing makedeps
and add pkgver() and adjust the source url to not download a master snapshot
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 662ecc0b0293..a1fb112a48ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = ubertooth-git
- pkgdesc = an open source wireless development platform suitable for Bluetooth experimentation
- pkgver = 2017.03.R2
+ pkgdesc = open source wireless development platform suitable for Bluetooth experimentation
+ pkgver = 2020.12.R1.r33.ge0fd34d
pkgrel = 1
- epoch = 2
url = https://github.com/greatscottgadgets/ubertooth
arch = x86_64
arch = i686
license = GPL2
- depends = libbtbb
- depends = libusbx
+ makedepends = git
+ makedepends = cmake
+ depends = libbtbb-git
+ depends = libusb
depends = libpcap
depends = python
- source = https://github.com/greatscottgadgets/ubertooth/archive/master.zip
+ source = git+https://github.com/greatscottgadgets/ubertooth/
md5sums = SKIP
pkgname = ubertooth-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8cecfb6ee519..d07f694b7af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
+# Contributor: Lex Black <autumn-wind@web.de>
+
_gitname=ubertooth
pkgname=ubertooth-git
-pkgver=2017.03.R2
-epoch=2
+pkgver=2020.12.R1.r33.ge0fd34d
pkgrel=1
-pkgdesc="an open source wireless development platform suitable for Bluetooth experimentation"
+pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth"
arch=('x86_64' 'i686')
license=('GPL2')
-depends=('libbtbb-git' 'libusbx' 'libpcap' 'python')
-source=("https://github.com/greatscottgadgets/ubertooth/archive/master.zip")
+depends=('libbtbb-git' 'libusb' 'libpcap' 'python')
+makedepends=('git' 'cmake')
+source=(git+https://github.com/greatscottgadgets/ubertooth/)
md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --tags --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "${srcdir}/${_gitname}-master/host/"
+ cd "$_gitname/host/"
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
@@ -20,6 +28,6 @@ build() {
}
package() {
- cd "${srcdir}/${_gitname}-master/host/build/"
+ cd "$_gitname/host/build/"
make install
}