summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2021-11-25 14:10:43 +0100
committerPopolon2021-11-25 14:10:43 +0100
commit20d055455d71a6e4b22157ca65a2238cd0ec1eb6 (patch)
tree23f0e908a1bea197b30d26fe87c4453f58c380f6
downloadaur-20d055455d71a6e4b22157ca65a2238cd0ec1eb6.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efa30b51f857
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ubgpsuite-git
+ pkgdesc = Micro BGP Suite and Utility library
+ pkgver = r67.f214c5e
+ pkgrel = 1
+ url = https://git.doublefourteen.io/bgp/ubgpsuite
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ arch = riscv32
+ arch = riscv64
+ license = GPL3
+ license = GPL lesser 3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ provides = upkgbuild
+ conflicts = upkgbuild
+ source = git+https://git.doublefourteen.io/bgp/ubgpsuite.git
+ sha256sums = SKIP
+
+pkgname = ubgpsuite-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04c1306e842d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+_pkgname=ubgpsuite
+pkgname=${_pkgname}-git
+pkgver=r67.f214c5e
+pkgrel=1
+pkgdesc="Micro BGP Suite and Utility library"
+url="https://git.doublefourteen.io/bgp/ubgpsuite"
+license=("GPL3" "GPL lesser 3")
+arch=(i686 x86_64 armv7h aarch64 riscv32 riscv64)
+#depends=(build)
+makedepends=('git' 'meson' 'ninja')
+provides=(upkgbuild)
+conflicts=(upkgbuild)
+source=("git+https://git.doublefourteen.io/bgp/ubgpsuite.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${srcdir}/${_pkgname}
+ meson build --buildtype=release --prefix=/usr
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}/build/
+ ninja
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/
+ DESTDIR="${pkgdir}" meson install -C build
+}