summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-06-26 22:45:26 +0100
committerGrey Christoforo2020-06-26 22:45:26 +0100
commitf694d7451e034294d66d3d5efa259994d80e831d (patch)
tree37e34eea73434706b1d75fd195c2eff28f9453b3
parent3a2b5138c17765c634a06480d104d14cb9415098 (diff)
downloadaur-f694d7451e034294d66d3d5efa259994d80e831d.tar.gz
fix dtb
-rw-r--r--PKGBUILD2
-rw-r--r--boot.txt.v31
2 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 549b62e47e3f..0477d0da49b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
'mkscr')
md5sums=('3b10951fa62e91433d0045a29a8588b0'
'69e883f0b8d1686b32bdf79684623f06'
- 'be8abe44b86d63428d7ac3acc64ee3bf'
+ '470c1e797acf34fa8d5e05debf02ef43'
'96d327ad1824134515d3ec25b4ffd7c6')
prepare() {
diff --git a/boot.txt.v3 b/boot.txt.v3
index 33c32cfa9271..ec9056e33a78 100644
--- a/boot.txt.v3
+++ b/boot.txt.v3
@@ -3,6 +3,7 @@
# Set root partition to the second partition of boot device
part uuid ${devtype} ${devnum}:2 uuid
+setenv fdtfile /dtbs/broadcom/bcm2711-rpi-4-b.dtb
setenv bootargs console=ttyS1,115200 console=tty0 root=PARTUUID=${uuid} rw rootwait smsc95xx.macaddr="${usbethaddr}"
if load ${devtype} ${devnum}:${bootpart} ${kernel_addr_r} /Image; then