summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Chen2020-11-24 15:54:07 +0800
committerJack Chen2020-11-24 15:54:07 +0800
commitce77be6dd7bca5594818a4c58de0aafe689da86e (patch)
tree19608f0dd03b16bd9d9756393937f49664d216ee
parent2a8170b7cb68329e5a52e77f96ab5374262490d2 (diff)
downloadaur-ce77be6dd7bca5594818a4c58de0aafe689da86e.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--uboot-tinkerboard.install2
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e4fef77261..6ffd914cf682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = uboot-tinkerboard
install = uboot-tinkerboard.install
arch = armv7h
license = GPL2
- makedepends = findutils
makedepends = curl
depends = uboot-tools
provides = uboot
@@ -19,7 +18,8 @@ pkgbase = uboot-tinkerboard
source = uboot-tinkerboard.install
source = https://github.com/redchenjs/armbian-ci/releases/download/v5.8.18-rockchip/linux-u-boot-current-tinkerboard_20.11.0-trunk_armhf.deb
sha512sums = 6a83f5b62703079691df948ba5e134009053157d72f7cbc46dfa4218d88ae97386b39af988c94e8bc6022ad6332339e5e4c443a79b18e5eb3772129e847ec861
- sha512sums = fb1ad6e15affee759ee5eb39db800a6b82ce7c7ba7d1388b2f840741603d6159bec86dddc484c88a0c12756e9a943146eabe054f3381f6d51c407fdaba92a981
+ sha512sums = a906e142398b53d5c08679c01c884c9366159757fe143f21db69d8c54b4ea29b9c1680da60de2e0201b67ea483aab1ed3d564d66bd6ccdedcc46ecbfb6968072
sha512sums = c117e76eecce9d4c677a7a643f44f6a4a8d760cc9d14cb3912dce59bcc15602ab254e6d39eff692b3a25e39845691c339230644b34f1b90c351c5a925fd6ff51
pkgname = uboot-tinkerboard
+
diff --git a/PKGBUILD b/PKGBUILD
index b8f12dae544b..df6ae844e28c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="U-Boot for Tinker Board / S"
arch=('armv7h')
url="https://github.com/redchenjs/armbian-ci"
license=('GPL2')
-makedepends=('findutils' 'curl')
+makedepends=('curl')
depends=('uboot-tools')
provides=('uboot' 'uboot-tinkerboard')
install=$pkgname.install
@@ -22,7 +22,7 @@ source=(
)
sha512sums=(
'6a83f5b62703079691df948ba5e134009053157d72f7cbc46dfa4218d88ae97386b39af988c94e8bc6022ad6332339e5e4c443a79b18e5eb3772129e847ec861'
- 'fb1ad6e15affee759ee5eb39db800a6b82ce7c7ba7d1388b2f840741603d6159bec86dddc484c88a0c12756e9a943146eabe054f3381f6d51c407fdaba92a981'
+ 'a906e142398b53d5c08679c01c884c9366159757fe143f21db69d8c54b4ea29b9c1680da60de2e0201b67ea483aab1ed3d564d66bd6ccdedcc46ecbfb6968072'
"$(curl -s -L https://github.com/redchenjs/armbian-ci/releases/download/v$_kernel-rockchip/linux-u-boot-current-tinkerboard_$pkgver-trunk_armhf.deb.sha512sum)"
)
noextract=("${source[@]##*/}")
@@ -44,5 +44,8 @@ package() {
install -Dm644 boot.cmd "$pkgdir/boot/boot.cmd"
install -Dm644 "usr/lib/linux-u-boot-current-tinkerboard_$pkgver-trunk_armhf/u-boot-rockchip-with-spl.bin" "$pkgdir/usr/lib/u-boot/u-boot-rockchip-with-spl.bin"
- sed -r -i 's#DIR=.*#DIR=/usr/lib/u-boot#' "$pkgdir/usr/lib/u-boot/platform_install.sh"
+
+ sed -i 's# > /dev/null 2>&1.*##' "$pkgdir/usr/lib/u-boot/platform_install.sh"
+ sed -i 's#DIR=.*#DIR=/usr/lib/u-boot#' "$pkgdir/usr/lib/u-boot/platform_install.sh"
+ echo 'write_uboot_platform $DIR $1' >> "$pkgdir/usr/lib/u-boot/platform_install.sh"
}
diff --git a/uboot-tinkerboard.install b/uboot-tinkerboard.install
index 1aefa7a1e8ed..b9dcf6d82b27 100644
--- a/uboot-tinkerboard.install
+++ b/uboot-tinkerboard.install
@@ -1,4 +1,6 @@
post_install() {
+ echo '# Install U-Boot to SD / MMC card:'
+ echo '# sh /usr/lib/u-boot/platform_install.sh /dev/mmcblkX'
mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr
}