summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-12-22 22:18:01 +0100
committerml2020-12-22 22:22:12 +0100
commit7fb6918dbbec66bef524cd381db11fd83503327f (patch)
tree4512cf8422b95494a9a58e59a0fb62681d16e34b
parent034c9331f9a7d84675abd5afa028117173902e67 (diff)
downloadaur-7fb6918dbbec66bef524cd381db11fd83503327f.tar.gz
updpkg: ubports-installer-git 0.8.2_beta.r0.ga55cc1a-1
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore6
-rw-r--r--01-disable-update-check.patch20
-rw-r--r--02-never-udev.patch12
-rw-r--r--03-electrondist.patch (renamed from electrondist.patch)0
-rw-r--r--PKGBUILD57
-rw-r--r--disable-update-udev-prompts.patch48
7 files changed, 70 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 868f3c62accb..a4652c310c22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ubports-installer-git
pkgdesc = A simple tool to install Ubuntu Touch on UBports devices
- pkgver = 0.6.0_beta.r0.g4712efb
+ pkgver = 0.8.2_beta.r0.ga55cc1a
pkgrel = 1
url = https://github.com/ubports/ubports-installer
arch = any
@@ -15,12 +15,14 @@ pkgbase = ubports-installer-git
source = ubports-installer-git::git+https://github.com/ubports/ubports-installer.git
source = ubports-installer
source = ubports-installer.desktop
- source = disable-update-udev-prompts.patch
- source = electrondist.patch
+ source = 01-disable-update-check.patch
+ source = 02-never-udev.patch
+ source = 03-electrondist.patch
sha256sums = SKIP
sha256sums = e3167aa1469a33d1eca4dae377ed51675bea08e61e6d17f94f83a241538be56b
sha256sums = 7f59cb66ab7e59caeff93f697e47f26f43a9a221258f4d89dee580e41dd7a39a
- sha256sums = 6d2be9f0d81fdd3ea6e95585457f967d9889c5884c1645b4212ea95add202f4e
+ sha256sums = f5a47dd84c2ce46528385a673d93e465132a80a5a72de5b4cf41e055f9f60fe4
+ sha256sums = a9d899eaf4e8a004c20d7d9ff6af696aa9cd5602e5e95583f4fe27ecaa7aa03f
sha256sums = 768fcea52f63fed0bebb61861437db5f7e1f00358ad594c8d5593adc43a0f0c0
pkgname = ubports-installer-git
diff --git a/.gitignore b/.gitignore
index db5a24b6e31c..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1 @@
-/pkg/
-/src/
-/*-git/
-/*.log
-/*.tar*
+*
diff --git a/01-disable-update-check.patch b/01-disable-update-check.patch
new file mode 100644
index 000000000000..70994acc6fd2
--- /dev/null
+++ b/01-disable-update-check.patch
@@ -0,0 +1,20 @@
+diff -ura package.orig/src/main.js package.new/src/main.js
+--- package.orig/src/main.js 2020-12-22 21:55:07.535806928 +0100
++++ package.new/src/main.js 2020-12-22 21:58:31.700431931 +0100
+@@ -66,16 +66,6 @@
+ // Tasks we need for every start and restart
+ mainWindow.webContents.on("did-finish-load", () => core.prepare(cli.file));
+
+- // Task we need only on the first start
+- mainWindow.webContents.once("did-finish-load", () => {
+- updater
+- .isOutdated()
+- .then(updateUrl => {
+- if (updateUrl) mainEvent.emit("user:update-available", updateUrl);
+- })
+- .catch(e => log.debug(e)); // Ignore errors, since this is non-essential
+- });
+-
+ mainWindow.loadURL(
+ url.format({
+ pathname: path.join(__dirname, "html/index.html"),
diff --git a/02-never-udev.patch b/02-never-udev.patch
new file mode 100644
index 000000000000..68bae214bb47
--- /dev/null
+++ b/02-never-udev.patch
@@ -0,0 +1,12 @@
+diff -ura package.orig/src/lib/settings.js package.new/src/lib/settings.js
+--- package.orig/src/lib/settings.js 2020-12-22 21:55:07.535806928 +0100
++++ package.new/src/lib/settings.js 2020-12-22 22:02:04.930637631 +0100
+@@ -39,7 +39,7 @@
+ },
+ udev: {
+ type: "boolean",
+- default: false
++ default: true
+ },
+ windowsDrivers: {
+ type: "boolean",
diff --git a/electrondist.patch b/03-electrondist.patch
index 6f9487677499..6f9487677499 100644
--- a/electrondist.patch
+++ b/03-electrondist.patch
diff --git a/PKGBUILD b/PKGBUILD
index 22ea76984691..b25adf0bc9af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: ml <>
pkgname=ubports-installer-git
-pkgver=0.6.0_beta.r0.g4712efb
+pkgver=0.8.2_beta.r0.ga55cc1a
pkgrel=1
pkgdesc='A simple tool to install Ubuntu Touch on UBports devices'
arch=('any')
@@ -10,48 +10,53 @@ depends=('android-tools' 'android-udev' 'electron')
makedepends=('git' 'npm')
provides=('ubports-installer')
conflicts=('ubports-installer')
-source=("${pkgname}::git+${url}.git"
+source=("$pkgname::git+$url.git"
ubports-installer
ubports-installer.desktop
- disable-update-udev-prompts.patch
- electrondist.patch)
+ 01-disable-update-check.patch
+ 02-never-udev.patch
+ 03-electrondist.patch)
sha256sums=('SKIP'
'e3167aa1469a33d1eca4dae377ed51675bea08e61e6d17f94f83a241538be56b'
'7f59cb66ab7e59caeff93f697e47f26f43a9a221258f4d89dee580e41dd7a39a'
- '6d2be9f0d81fdd3ea6e95585457f967d9889c5884c1645b4212ea95add202f4e'
+ 'f5a47dd84c2ce46528385a673d93e465132a80a5a72de5b4cf41e055f9f60fe4'
+ 'a9d899eaf4e8a004c20d7d9ff6af696aa9cd5602e5e95583f4fe27ecaa7aa03f'
'768fcea52f63fed0bebb61861437db5f7e1f00358ad594c8d5593adc43a0f0c0')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/-/_/;s/-/.r/;s/-/./'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/-/_/;s/-/.r/;s/-/./'
}
prepare() {
- cd "$pkgname"
- for p in ../{disable-update-udev-prompts,electrondist}.patch; do
- patch -Np1 <"$p"
- done
- npm install --no-audit --no-progress --no-fund --ignore-scripts electron@"$(</usr/lib/electron/version)"
- npm run prerender
+ cd "$pkgname"
+ for p in ../{01-disable-update-check,02-never-udev,03-electrondist}.patch; do
+ echo "Applying $p"
+ patch -Np1 <"$p"
+ done
+ npm install --no-audit --no-progress --no-fund --ignore-scripts electron@"$(</usr/lib/electron/version)"
+ npm run prerender
}
build() {
- cd "$pkgname"
- node ./build.js -o linux -p dir -a x64
+ cd "$pkgname"
+ node ./build.js -o linux -p dir -a x64
}
package() {
- install -Dm644 -t "${pkgdir}/usr/share/applications" ubports-installer.desktop
- install -Dm755 -t "${pkgdir}/usr/bin" ubports-installer
+ install -Dm644 -t "$pkgdir/usr/share/applications" ubports-installer.desktop
+ install -Dm755 -t "$pkgdir/usr/bin" ubports-installer
- cd "${pkgname}"
- install -Dm644 -t "${pkgdir}/usr/share/ubports-installer" dist/linux-unpacked/resources/app.asar
+ cd "$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/ubports-installer" dist/linux-unpacked/resources/app.asar
- find ./dist/linux-unpacked/resources/app.asar.unpacked -type d \( -name linux -o -name mac \) -print -exec rm -r {} +
- cp -rt "${pkgdir}/usr/share/ubports-installer" dist/linux-unpacked/resources/app.asar.unpacked
+ find ./dist/linux-unpacked/resources/app.asar.unpacked -type d \( -name linux -o -name mac \) -print -exec rm -r {} +
+ cp -rt "$pkgdir/usr/share/ubports-installer" dist/linux-unpacked/resources/app.asar.unpacked
- cd build/icons
- for i in *x*.png; do
- install -Dm644 "$i" "${pkgdir}/usr/share/icons/hicolor/${i%.png}/apps/ubports-installer.png"
- done
+ find "$pkgdir" -type d -empty -delete -print
+
+ cd build/icons
+ for i in *x*.png; do
+ install -Dm644 "$i" "$pkgdir/usr/share/icons/hicolor/${i%.png}/apps/ubports-installer.png"
+ done
}
diff --git a/disable-update-udev-prompts.patch b/disable-update-udev-prompts.patch
deleted file mode 100644
index f144d73c36ce..000000000000
--- a/disable-update-udev-prompts.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ura package.orig/src/main.js package.new/src/main.js
---- package.orig/src/main.js 2020-11-04 00:50:50.620740528 +0100
-+++ package.new/src/main.js 2020-11-04 00:51:13.738986029 +0100
-@@ -95,7 +95,7 @@
- },
- udev: {
- type: "boolean",
-- default: false
-+ default: true
- },
- windowsDrivers: {
- type: "boolean",
-@@ -547,22 +547,6 @@
- });
- });
-
-- // Task we need only on the first start
-- mainWindow.webContents.once("did-finish-load", () => {
-- utils
-- .getUpdateAvailable()
-- .then(() => {
-- utils.log.info(
-- "This is not the latest version of the UBports Installer! Please update: https://devices.ubuntu-touch.io/installer/" +
-- (global.packageInfo.package
-- ? "?package=" + global.packageInfo.package
-- : "")
-- );
-- mainWindow.webContents.send("user:update-available");
-- })
-- .catch(() => {}); // Ignore errors, since this is non-essential
-- });
--
- mainWindow.loadURL(
- url.format({
- pathname: path.join(__dirname, "html/index.html"),
-diff -ura package.orig/src/pug/index.pug package.new/src/pug/index.pug
---- package.orig/src/pug/index.pug 2020-11-04 00:50:50.622740549 +0100
-+++ package.new/src/pug/index.pug 2020-11-04 00:51:23.690090642 +0100
-@@ -45,9 +45,7 @@
- include modals/unlock
- include modals/result
- // high prio
-- include modals/udev
- include modals/windows-drivers
-- include modals/new-update
- // errors
- include modals/low-power
- include modals/connection-lost