summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2023-04-11 20:10:34 +0200
committerMarkus Pesch2023-04-11 20:17:57 +0200
commit67177329bb24ca371690dbeeb7d55bf698834320 (patch)
treeb597acfc97a0bbf81445436724dea6906f383896
parent7bfb972b8073bf5908b4aae0227b7073c07920ab (diff)
downloadaur-67177329bb24ca371690dbeeb7d55bf698834320.tar.gz
fix: add Ubuntu 22.10 - kinetic
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a662f5c944b8..bbe1b516c639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ubuntu-backgrounds
pkgdesc = All backgrounds of Ubuntu
- pkgver = 0.2.0
- pkgrel = 3
+ pkgver = 0.4.0
+ pkgrel = 1
url = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers
arch = any
license = Commons Attribution-ShareAlike 3.0 Unported
- source = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/ubuntu-wallpapers_22.04.4.orig.tar.gz
- sha256sums = 83a9469e84c908d29f9fb2484029575a2d05548f9d984dca556740b622c5dd1e
+ source = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/ubuntu-wallpapers_23.04.1.orig.tar.gz
+ sha256sums = f0731d916ad51162921dfa8e5f2fb028d07099c6c02bcd136ab0ee3fb169ddd3
pkgname = ubuntu-backgrounds-artful
pkgdesc = The backgrounds included in Ubuntu 17.10 artful
@@ -29,6 +29,9 @@ pkgname = ubuntu-backgrounds-impish
pkgname = ubuntu-backgrounds-karmic
pkgdesc = The backgrounds included in Ubuntu 9.10 karmic
+pkgname = ubuntu-backgrounds-kinetic
+ pkgdesc = The backgrounds included in Ubuntu 22.10 kinetic
+
pkgname = ubuntu-backgrounds-lucid
pkgdesc = The backgrounds included in Ubuntu 10.04 lucid
diff --git a/PKGBUILD b/PKGBUILD
index 8085848920bf..2017663db9f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ pkgname=(
ubuntu-backgrounds-hirsute
ubuntu-backgrounds-impish
ubuntu-backgrounds-karmic
+ ubuntu-backgrounds-kinetic
ubuntu-backgrounds-lucid
ubuntu-backgrounds-maverick
ubuntu-backgrounds-natty
@@ -23,16 +24,16 @@ pkgname=(
ubuntu-backgrounds-yakkety
ubuntu-backgrounds-zesty
)
-pkgver=0.2.0
-pkgrel=3
+pkgver=0.4.0
+pkgrel=1
pkgdesc="All backgrounds of Ubuntu"
license=('Commons Attribution-ShareAlike 3.0 Unported')
arch=('any')
url="http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers"
-_pkgver=22.04.4
+_pkgver=23.04.1
source=("${url}/ubuntu-wallpapers_${_pkgver}.orig.tar.gz")
-sha256sums=('83a9469e84c908d29f9fb2484029575a2d05548f9d984dca556740b622c5dd1e')
+sha256sums=('f0731d916ad51162921dfa8e5f2fb028d07099c6c02bcd136ab0ee3fb169ddd3')
package_ubuntu-backgrounds-artful() {
_pkgname=${pkgname/${pkgbase}-/}
@@ -191,6 +192,24 @@ package_ubuntu-backgrounds-karmic() {
package_wallpaper ${_pkgname} ${wallapers[@]}
}
+package_ubuntu-backgrounds-kinetic() {
+ _pkgname=${pkgname/${pkgbase}-/}
+
+ pkgdesc="The backgrounds included in Ubuntu 22.10 ${pkgname/${pkgbase}-/}"
+
+ local wallpapers=(
+ "Kinetic_Kudu_by_Joshua_T_dark.jpg"
+ "Kinetic_Kudu_by_Joshua_T_light.jpg"
+ "Obersee_by_Uday_Nakade.jpg"
+ "Reflection_by_Juliette_Taka.png"
+ "Saffron_by_Rakesh_Yadav.png"
+ "Sunset_Over_Lake_Lugano_by_Alexey_Kulik.jpg"
+ "Twisted_Gradients_by_Gustavo_Brenner.png"
+ )
+
+ package_wallpaper ${_pkgname} ${wallapers[@]}
+}
+
package_ubuntu-backgrounds-lucid() {
_pkgname=${pkgname/${pkgbase}-/}
@@ -570,4 +589,4 @@ package_wallpaper() {
# license
install -D --mode 644 ${srcdir}/ubuntu-wallpapers-${_pkgver}/COPYING ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
-} \ No newline at end of file
+}