summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Pesch2023-04-11 20:16:36 +0200
committerMarkus Pesch2023-04-11 20:18:48 +0200
commitc96fdc110a12654ee43f61c34cadda38691ef05a (patch)
treeb1643757f35fef7080fafb5ac14bb023b12bcdfd
parent67177329bb24ca371690dbeeb7d55bf698834320 (diff)
downloadaur-c96fdc110a12654ee43f61c34cadda38691ef05a.tar.gz
fix: add Ubuntu 23.04 - kinetic
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbe1b516c639..65e86502080f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ubuntu-backgrounds
pkgdesc = All backgrounds of Ubuntu
- pkgver = 0.4.0
+ pkgver = 0.5.0
pkgrel = 1
url = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers
arch = any
@@ -35,6 +35,9 @@ pkgname = ubuntu-backgrounds-kinetic
pkgname = ubuntu-backgrounds-lucid
pkgdesc = The backgrounds included in Ubuntu 10.04 lucid
+pkgname = ubuntu-backgrounds-lunar
+ pkgdesc = The backgrounds included in Ubuntu 23.04 lunar
+
pkgname = ubuntu-backgrounds-maverick
pkgdesc = The backgrounds included in Ubuntu 10.10 maverick
diff --git a/PKGBUILD b/PKGBUILD
index 2017663db9f3..997f3d9de16c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ pkgname=(
ubuntu-backgrounds-karmic
ubuntu-backgrounds-kinetic
ubuntu-backgrounds-lucid
+ ubuntu-backgrounds-lunar
ubuntu-backgrounds-maverick
ubuntu-backgrounds-natty
ubuntu-backgrounds-oneiric
@@ -24,7 +25,7 @@ pkgname=(
ubuntu-backgrounds-yakkety
ubuntu-backgrounds-zesty
)
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="All backgrounds of Ubuntu"
license=('Commons Attribution-ShareAlike 3.0 Unported')
@@ -239,6 +240,25 @@ package_ubuntu-backgrounds-lucid() {
package_wallpaper ${_pkgname} ${wallapers[@]}
}
+package_ubuntu-backgrounds-lunar() {
+ _pkgname=${pkgname/${pkgbase}-/}
+
+ pkgdesc="The backgrounds included in Ubuntu 23.04 ${pkgname/${pkgbase}-/}"
+
+ local wallpapers=(
+ "Copper_Mountain_by_Eduardo_Battaglia.jpg"
+ "Flow_by_Emanuele_Santoro.png"
+ "Lunar-lobster-side_by_Gixo-light.png"
+ "LunarCatcher_by_Espio347.png"
+ "Multiverse_by_Emanuele_Santoro.png"
+ "Startrail_by_Hajime_Mizuno.jpg"
+ "Warm_Filament_by_Eduardo_Battaglia.jpg"
+ "winter-is-leaving_by_Gixo-light.png"
+ )
+
+ package_wallpaper ${_pkgname} ${wallapers[@]}
+}
+
package_ubuntu-backgrounds-maverick() {
_pkgname=${pkgname/${pkgbase}-/}