summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-12-21 23:18:48 +0100
committerLuca Weiss2016-12-21 23:18:48 +0100
commitd07be9e8af7dde8538d9214742bf10d591419c2d (patch)
tree65b1f1c0560fdbccdd0aa120009ef32dcfc43762
parenteda69a19871c78cc2c2e2252fe9fa2b60c210689 (diff)
downloadaur-d07be9e8af7dde8538d9214742bf10d591419c2d.tar.gz
Fix build thanks to themihai on launchpad
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fb217bfc753..b2c42a7d9f6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ubuntu-device-flash
pkgver=0.34
-pkgrel=1
+pkgrel=2
pkgdesc="Tools to work with Ubuntu Touch"
url="https://launchpad.net/goget-ubuntu-touch"
arch=('x86_64' 'i686')
@@ -25,9 +25,13 @@ build() {
echo "go get: downloading dependencies..."
go get -v -d
+ cd $GOPATH/src/github.com/jessevdk/go-flags
+ git checkout e790d18a5622970eed9448823164da625077784d
+
echo "go build: building executable..."
# Prepare executable
- go build
+ cd $GOPATH/src/launchpad.net/goget-ubuntu-touch/ubuntu-device-flash
+ go install
}
package() {
@@ -37,7 +41,7 @@ package() {
"$pkgdir/usr/share/licenses/$pkgname/COPYING"
# Package executables
- install -Dm755 "$SOURCE_PATH/${pkgname}/${pkgname}" \
+ install -Dm755 "$srcdir/build/bin/$pkgname" \
"$pkgdir/usr/bin/$pkgname"
}