summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorautinerd2022-07-10 14:37:23 +0200
committerautinerd2022-07-10 14:37:23 +0200
commitb0cefdba8c3987986545a383786c4ec2d35c20c9 (patch)
treef21473b23b58ec6deb12d6ff3808bb8b5274dfdf
parent1793312dbe098ab12d492293bddaaf32ac481cd3 (diff)
downloadaur-b0cefdba8c3987986545a383786c4ec2d35c20c9.tar.gz
bugfix thanks to @ewout
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--setuptools-bugfix.patch11
4 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fceb9aeb279..107857abece7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ubuntu-wallpapers
pkgdesc = The default Wallpapers for Ubuntu
pkgver = 22.04.4
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/ubuntu-wallpapers
arch = any
license = custom
@@ -9,7 +9,9 @@ pkgbase = ubuntu-wallpapers
makedepends = python-setuptools
source = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/ubuntu-wallpapers_22.04.4.orig.tar.gz
source = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/ubuntu-wallpapers_22.04.4-0ubuntu1.debian.tar.xz
+ source = setuptools-bugfix.patch
sha256sums = 83a9469e84c908d29f9fb2484029575a2d05548f9d984dca556740b622c5dd1e
sha256sums = 430a61aa87de2fc12ba3a7ba583df16643839c3b14c7d9138d67e43d43767a6b
+ sha256sums = fee8ef60ea8ecfbf847fd45b30db7efc7bf233d9d6e5f67b14f2f29e585fc4ac
pkgname = ubuntu-wallpapers
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..62bb40b21878 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!/*.patch \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3c571fa3761b..8b07d3900b07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,11 @@
# Contributor: Michael Healy <horsemanoffaith@gmail.com>
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Contributor: SoftwareRat <chenxiaolong@cxl.epac.to>
+# Contributor: Ewout van Mansom <ewout@vanmansom.name>
pkgname='ubuntu-wallpapers'
pkgver=22.04.4
-pkgrel=1
+pkgrel=2
pkgdesc='The default Wallpapers for Ubuntu'
arch=('any')
url='https://launchpad.net/ubuntu-wallpapers'
@@ -17,15 +18,23 @@ makedepends=('python-distutils-extra' 'python-setuptools')
# https://packages.ubuntu.com/source/ubuntu-wallpapers
# http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/
-source=("${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
- "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}-0ubuntu1.debian.tar.xz")
+source=(
+ "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
+ "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}-0ubuntu1.debian.tar.xz"
+ 'setuptools-bugfix.patch'
+)
sha256sums=('83a9469e84c908d29f9fb2484029575a2d05548f9d984dca556740b622c5dd1e'
- '430a61aa87de2fc12ba3a7ba583df16643839c3b14c7d9138d67e43d43767a6b')
+ '430a61aa87de2fc12ba3a7ba583df16643839c3b14c7d9138d67e43d43767a6b'
+ 'fee8ef60ea8ecfbf847fd45b30db7efc7bf233d9d6e5f67b14f2f29e585fc4ac')
prepare() {
cd "${pkgname}-${pkgver}"
# The setup.py script reads the package version from debian/*
ln -sfv ../debian .
+ # Patch setuptools to work around new behavior in setuptools
+ # Eventually this can be removed, whenever Ubuntu/Debian package maintainers
+ # Stumble on this and fix it upstream.
+ patch --forward --strip=1 --input="${srcdir}/setuptools-bugfix.patch"
}
package() {
diff --git a/setuptools-bugfix.patch b/setuptools-bugfix.patch
new file mode 100644
index 000000000000..35cf95f67780
--- /dev/null
+++ b/setuptools-bugfix.patch
@@ -0,0 +1,11 @@
+diff --color --unified --recursive --text package.orig/setup.py package.new/setup.py
+--- package.orig/setup.py 2022-07-01 12:03:01.556073789 +0200
++++ package.new/setup.py 2022-07-01 12:03:52.441063442 +0200
+@@ -15,6 +15,7 @@
+ setup(
+ name = 'ubuntu-wallpapers',
+ version = version,
++ packages=[],
+ data_files=[('share/backgrounds', glob.glob('*.png')+glob.glob('*.jpg')),
+ ('share/backgrounds/contest', glob.glob('contest/*.xml')),
+ ],