summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUdit Karode2019-07-30 10:12:52 +0000
committerUdit Karode2019-07-30 10:12:52 +0000
commit3edf44b102a4b8de29c499f8eac126faaaeef721 (patch)
tree1bd884ed068b83169d9d8e9b45f0eb2a5a17130e
parentddf8e87f6701df0155c108bb886f1121ee6b4545 (diff)
downloadaur-3edf44b102a4b8de29c499f8eac126faaaeef721.tar.gz
pkgbuild: move BIN to /var/cache, update to version 2.9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aa22bd2a0b6..910b8520fa77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = ucc
pkgdesc = A bash based wrapper around the DOS based tcc, lets you compile TurboC(++) programs directly from the terminal.
- pkgver = 2.8
+ pkgver = 2.9
pkgrel = 1
url = https://github.com/uditkarode/ucc.git
arch = x86_64
- license = sha265
+ license = Apache
depends = dosbox
depends = git
depends = wget
diff --git a/PKGBUILD b/PKGBUILD
index f93f4ec3459d..5f7263a75077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Udit Karode <udit.karode@gmail.com>
pkgname="ucc"
-pkgver=2.8
+pkgver=2.9
pkgrel=1
pkgdesc="A bash based wrapper around the DOS based tcc, lets you compile TurboC(++) programs directly from the terminal."
arch=("x86_64")
url="https://github.com/uditkarode/ucc.git"
-license=('sha265')
+license=('Apache')
depends=('dosbox' 'git' 'wget' 'curl')
source=(${pkgname}::git+https://github.com/uditkarode/ucc.git)
md5sums=('SKIP')
package() {
install -Dm777 "${pkgname}/ucc" "${pkgdir}/usr/bin/ucc"
+ mkdir -p "${pkgdir}/var/cache/ucc"
+ cp -r "${pkgname}/BIN" "${pkgdir}/var/cache/ucc/BIN"
chmod a+x "${pkgdir}/usr/bin/ucc"
}