summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-05 17:24:40 +0800
committerChocobo12019-05-05 17:32:36 +0800
commitebc6e5f51070574c54f879cfa25d6b95e122bace (patch)
tree4eaf0178c7878e3cbc8b742b4249920ef6487b46
downloadaur-ebc6e5f51070574c54f879cfa25d6b95e122bace.tar.gz
newpkg: uci-git r511.g4c8b4d6-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a87cf49a2da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = uci-git
+ pkgdesc = OpenWrt unified configuration interface
+ pkgver = r511.g4c8b4d6
+ pkgrel = 1
+ url = https://openwrt.org/docs/techref/uci
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ depends = libubox
+ depends = lua
+ provides = uci
+ conflicts = uci
+ source = git+https://git.openwrt.org/project/uci.git
+ sha256sums = SKIP
+
+pkgname = uci-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c76dad653c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=uci-git
+pkgver=r511.g4c8b4d6
+pkgrel=1
+pkgdesc="OpenWrt unified configuration interface"
+arch=('i686' 'x86_64')
+url="https://openwrt.org/docs/techref/uci"
+license=('LGPL')
+depends=('glibc' 'libubox' 'lua')
+makedepends=('git' 'cmake')
+provides=('uci')
+conflicts=('uci')
+source=("git+https://git.openwrt.org/project/uci.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "uci"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "uci"
+
+ mkdir -p "_build" && cd "_build"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ ../
+ make
+}
+
+package() {
+ cd "uci"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+}