summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-26 14:51:53 +0800
committermaz-12015-10-26 14:51:53 +0800
commite7602a8d10249f8259895412a1d4e0686091f414 (patch)
tree0cab3af20f0799e58add9fb728bd4e940837b988
parentc46baf8d8325f76a587d234f03899be914682d9e (diff)
downloadaur-e7602a8d10249f8259895412a1d4e0686091f414.tar.gz
bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--fix_grub_install.patch12
-rw-r--r--fix_package_querying.patch13
-rw-r--r--modify_for_arch.patch (renamed from modify_path.patch)41
5 files changed, 44 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12837f45a297..f0d67d52dcde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,17 +19,13 @@ pkgbase = ucloner
source = ucloner-cmd.sh
source = ucloner.desktop
source = ucloner.png
- source = modify_path.patch
- source = fix_package_querying.patch
- source = fix_grub_install.patch
+ source = modify_for_arch.patch
md5sums = b7bf49a5516cb9e00943e06e3e73adf2
md5sums = 3dac4b28900e7be1068b502b7b848028
md5sums = 15efc60875b77125f8d5399797306955
md5sums = 32a9a04b595890e50fa10fe51823469a
md5sums = 1f913fe9ca34481134bc36e1045e9a20
- md5sums = 4966de605892a3a5c52d7fdd4b768f0d
- md5sums = c84c4aaba3bf5c7fbb6126190cb341ca
- md5sums = 1ce4d37e5531797196104c08825db0f7
+ md5sums = 712877e08bd19434501221d3f82e769f
pkgname = ucloner
diff --git a/PKGBUILD b/PKGBUILD
index 1c9b7cce5dc1..5ca9a7a1479e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,7 @@ source=(
'ucloner-cmd.sh'
'ucloner.desktop'
'ucloner.png'
- 'modify_path.patch'
- 'fix_package_querying.patch'
- 'fix_grub_install.patch'
+ 'modify_for_arch.patch'
)
md5sums=('b7bf49a5516cb9e00943e06e3e73adf2'
@@ -24,16 +22,12 @@ md5sums=('b7bf49a5516cb9e00943e06e3e73adf2'
'15efc60875b77125f8d5399797306955'
'32a9a04b595890e50fa10fe51823469a'
'1f913fe9ca34481134bc36e1045e9a20'
- '4966de605892a3a5c52d7fdd4b768f0d'
- 'c84c4aaba3bf5c7fbb6126190cb341ca'
- '1ce4d37e5531797196104c08825db0f7')
+ '712877e08bd19434501221d3f82e769f')
prepare() {
cd "${srcdir}/UCloner-$pkgver-$rev"
- patch -p1 < "${srcdir}/modify_path.patch"
- patch -p1 < "${srcdir}/fix_package_querying.patch"
- patch -p1 < "${srcdir}/fix_grub_install.patch"
+ patch -p1 < "${srcdir}/modify_for_arch.patch"
cd program
rm *.pyc
find -name '*.py' | xargs sed -i 's|#!/usr/bin/python$|#!/usr/bin/env python2|'
diff --git a/fix_grub_install.patch b/fix_grub_install.patch
deleted file mode 100644
index 1d5a9efa321b..000000000000
--- a/fix_grub_install.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur a/program/sh/install_grub.sh b/program/sh/install_grub.sh
---- a/program/sh/install_grub.sh 2010-07-14 12:53:44.000000000 +0800
-+++ b/program/sh/install_grub.sh 2015-10-26 14:15:50.935032106 +0800
-@@ -79,7 +79,7 @@
-
-
- echo "Generating grub.cfg ..."
--target_cmd "$target_dir" update-grub
-+target_cmd "$target_dir" grub-mkconfig -o /boot/grub/grub.cfg
-
-
- if [ $? -eq 0 ] ; then
diff --git a/fix_package_querying.patch b/fix_package_querying.patch
deleted file mode 100644
index 7564929c8513..000000000000
--- a/fix_package_querying.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur a/program/functions.py b/program/functions.py
---- a/program/functions.py 2010-12-04 17:18:57.000000000 +0000
-+++ b/program/functions.py 2015-10-13 09:34:01.093513450 +0000
-@@ -57,7 +57,7 @@
-- a = commands.getoutput( 'dpkg -l' )
-+ a = commands.getoutput( 'pacman -Q' )
- a = a.split( '\n' )
- for each in a:
-- if each[0:2] == 'ii' and each.split()[1] == pkg_name:
-+ if each.split()[0] == pkg_name:
- return True
-
- return False
diff --git a/modify_path.patch b/modify_for_arch.patch
index bac89f740501..a771a8c2893e 100644
--- a/modify_path.patch
+++ b/modify_for_arch.patch
@@ -1,6 +1,19 @@
diff -Naur a/program/functions.py b/program/functions.py
---- a/program/functions.py 2010-12-04 17:18:57.000000000 +0000
-+++ b/program/functions.py 2015-10-13 07:12:20.605894444 +0000
+--- a/program/functions.py 2010-12-05 01:18:57.000000000 +0800
++++ b/program/functions.py 2015-10-26 14:47:11.167286057 +0800
+@@ -54,10 +54,10 @@
+
+
+ def check_package_install( pkg_name ):
+- a = commands.getoutput( 'dpkg -l' )
++ a = commands.getoutput( 'pacman -Q' )
+ a = a.split( '\n' )
+ for each in a:
+- if each[0:2] == 'ii' and each.split()[1] == pkg_name:
++ if each.split()[0] == pkg_name:
+ return True
+
+ return False
@@ -279,7 +279,7 @@
def make_system_dirs( target_root ):
print _('Making system dirs ...')
@@ -41,3 +54,27 @@ diff -Naur a/program/functions.py b/program/functions.py
return defaultExcludes
+diff -Naur a/program/sh/install_grub.sh b/program/sh/install_grub.sh
+--- a/program/sh/install_grub.sh 2010-07-14 12:53:44.000000000 +0800
++++ b/program/sh/install_grub.sh 2015-10-26 14:46:53.829725481 +0800
+@@ -79,7 +79,7 @@
+
+
+ echo "Generating grub.cfg ..."
+-target_cmd "$target_dir" update-grub
++target_cmd "$target_dir" grub-mkconfig -o /boot/grub/grub.cfg
+
+
+ if [ $? -eq 0 ] ; then
+diff -Naur a/program/ucloner_cmd.py b/program/ucloner_cmd.py
+--- a/program/ucloner_cmd.py 2010-12-05 01:25:02.000000000 +0800
++++ b/program/ucloner_cmd.py 2015-10-26 14:48:39.320636280 +0800
+@@ -130,7 +130,7 @@
+ print 'functions.generate_fstab() done.'
+
+ # 生成 mtab
+- tmp = commands.getstatusoutput( 'touch ' + target_dir+'/etc/mtab' )
++ tmp = commands.getstatusoutput( 'ln -s /proc/self/mounts ' + target_dir+'/etc/mtab' )
+
+ # 修复休眠功能
+ ret = functions.fix_resume( target_dir, swappart )