summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2022-05-07 14:39:21 +0200
committerPeter Mattern2022-05-07 14:39:21 +0200
commitb6b1d969892ffeb0125b3c13b92378d625216b3a (patch)
tree635309b77b4844772a4c4a8e2b434411972fa054
parentb7f6d965b41bec74e258516918f369827f957835 (diff)
downloadaur-ucommon.tar.gz
Upstream update: release 7.0.1
Only available as snapshot within the VCS repository, neither announced on the homepage nor available on the download server, so rather kind of semi-official. But looking through the VCS commits strongly suggests it makes sense to use it, also picked by e. g. openSUSE or Debian. Relevant changes introduced by this release: * replace GNU Build System with CMake * use OpenSSL instead of GnuTLS
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b973f579d73..a18eff56522d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = ucommon
pkgdesc = GNU Common C++ is a class framework that was specifically designed for telephony applications.
- pkgver = 7.0.0
- pkgrel = 3
+ pkgver = 7.0.1
+ pkgrel = 1
url = https://www.gnu.org/software/commoncpp/
arch = i686
arch = x86_64
license = LGPL3
- depends = gnutls
- source = https://ftp.gnu.org/gnu/commoncpp/ucommon-7.0.0.tar.gz
- source = https://ftp.gnu.org/gnu/commoncpp/ucommon-7.0.0.tar.gz.sig
- validpgpkeys = 5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA
- sha256sums = 6ac9f76c2af010f97e916e4bae1cece341dc64ca28e3881ff4ddc3bc334060d7
- sha256sums = SKIP
+ makedepends = cmake
+ depends = openssl
+ source = https://git.savannah.gnu.org/cgit/commoncpp.git/snapshot/commoncpp-7.0.1.tar.gz
+ sha256sums = 99fd0e2c69f24e4ca93d01a14bc3fc4e40d69576f235f80f7a8ab37c16951f3e
pkgname = ucommon
diff --git a/PKGBUILD b/PKGBUILD
index da28689e955c..0fb99845d84e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,26 @@
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=ucommon
-pkgver=7.0.0
-pkgrel=3
+pkgver=7.0.1
+pkgrel=1
pkgdesc='GNU Common C++ is a class framework that was specifically designed for telephony applications.'
arch=('i686' 'x86_64')
url='https://www.gnu.org/software/commoncpp/'
license=('LGPL3')
-depends=('gnutls')
-source=("https://ftp.gnu.org/gnu/commoncpp/$pkgname-$pkgver.tar.gz"{,.sig})
-sha256sums=('6ac9f76c2af010f97e916e4bae1cece341dc64ca28e3881ff4ddc3bc334060d7'
- 'SKIP')
-validpgpkeys=('5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA')
+depends=('openssl')
+makedepends=('cmake')
+#source=("https://ftp.gnu.org/gnu/commoncpp/$pkgname-$pkgver.tar.gz"{,.sig})
+source=("https://git.savannah.gnu.org/cgit/commoncpp.git/snapshot/commoncpp-$pkgver.tar.gz")
+sha256sums=('99fd0e2c69f24e4ca93d01a14bc3fc4e40d69576f235f80f7a8ab37c16951f3e')
+#validpgpkeys=('5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA')
build() {
- cd ${pkgname}-${pkgver}
- CXXFLAGS+=" -std=c++14"
- ./configure --prefix=/usr --with-sslstack=gnu --enable-socks --enable-stdcpp --enable-atomics --with-pkg-config
+ mkdir build && cd build
+ cmake "${srcdir}"/commoncpp-$pkgver -DCMAKE_INSTALL_PREFIX=/usr
make
}
-check() {
- cd ${pkgname}-${pkgver}
- make check
-}
-
package() {
- cd ${pkgname}-${pkgver}
+ cd build
make DESTDIR="${pkgdir}" install
}