summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-07-05 21:28:44 +0200
committerMichael Straube2017-07-05 21:28:44 +0200
commitc5f1a2ec1cd66310195834c87e192157678006f0 (patch)
tree9880b1f5d306c7237fb4b1c95fe73fe6b6cfb244
parent86baacd9d813a1bb368690513cf92e35b1fb7071 (diff)
downloadaur-c5f1a2ec1cd66310195834c87e192157678006f0.tar.gz
Update to 2.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
-rw-r--r--patch-backup-lynxit.c20
-rw-r--r--patch-libdiscimage-misc_z.c10
-rw-r--r--patch-libdiscimage-unzip.h13
-rw-r--r--patch-misc-archive.c10
-rw-r--r--patch-misc-unzip.h13
-rw-r--r--patch-ucon64.c21
-rw-r--r--patch-ucon64_misc.c12
9 files changed, 26 insertions, 131 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01dec5067d0b..c46c49fea46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = ucon64
pkgdesc = A ROM backup tool and emulator's Swiss Army knife program.
- pkgver = 2.0.0
- pkgrel = 4
+ pkgver = 2.0.3
+ pkgrel = 1
url = http://ucon64.sourceforge.net/index.php
arch = i686
arch = x86_64
license = GPL
depends = zlib
- source = http://downloads.sourceforge.net/ucon64/ucon64-2.0.0-src.tar.gz
- source = patch-backup-lynxit.c
- source = patch-libdiscimage-misc_z.c
- source = patch-libdiscimage-unzip.h
- source = patch-misc-archive.c
- source = patch-misc-unzip.h
- source = patch-ucon64.c
+ source = https://downloads.sourceforge.net/ucon64/ucon64-2.0.3-src.tar.gz
source = patch-ucon64_misc.c
+ sha256sums = fdf158a4bc7c3a7d45a60ef495151f635ce39938799d373a29628f5985790bd2
+ sha256sums = f52d6e0cb307a2c0bc4e4ede0673139f5ddd704199ee12d15f58d2e394f25c80
pkgname = ucon64
diff --git a/PKGBUILD b/PKGBUILD
index b3d3f092f27c..f01b86d5875f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,35 @@
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=ucon64
-pkgver=2.0.0
-pkgrel=4
+pkgver=2.0.3
+pkgrel=1
pkgdesc="A ROM backup tool and emulator's Swiss Army knife program."
arch=('i686' 'x86_64')
url="http://ucon64.sourceforge.net/index.php"
-license="GPL"
+license=('GPL')
depends=('zlib')
-source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz \
- patch-backup-lynxit.c \
- patch-libdiscimage-misc_z.c \
- patch-libdiscimage-unzip.h \
- patch-misc-archive.c \
- patch-misc-unzip.h \
- patch-ucon64.c \
+source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz \
patch-ucon64_misc.c)
-md5sums=('33804256edb265d43bc3dbb9ada4441a'
- '0c315bce4b590749b7451b33f86d5b2d'
- '3a405c6696069b8799dce85c21c6c6e9'
- '249aaa950fba7bc9983b4dafdeaf37ab'
- '42057845212bf93dee24584912316494'
- 'fbd555b1fa8b0d6a1547fcca5110e8a9'
- 'a991ce0999b9724dec816fb1747b1237'
- 'edac4423575708755e7dc1a603538c01')
+sha256sums=('fdf158a4bc7c3a7d45a60ef495151f635ce39938799d373a29628f5985790bd2'
+ 'f52d6e0cb307a2c0bc4e4ede0673139f5ddd704199ee12d15f58d2e394f25c80')
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}-src/src
- for i in ../../patch*; do patch -p0 < $i; echo $i; done
+ cd ${pkgname}-${pkgver}-src/src
+
+ patch -p0 < ../../patch-ucon64_misc.c
+ sed -i 's|$(CFLAGS0)|"$(CFLAGS0)"|g' Makefile
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}-src/src
+ cd ${pkgname}-${pkgver}-src/src
+
./configure --prefix=/usr
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}-src/src
-
- install -Dm775 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ cd ${pkgname}-${pkgver}-src/src
- if [ -f libdiscmage/discmage.so ]; then
- install -Dm755 libdiscmage/discmage.so ${pkgdir}/usr/lib/discmage.so
- elif [ -f discmage.so ]; then
- install -Dm755 discmage.so ${pkgdir}/usr/lib/discmage.so
- fi
+ install -Dm775 ucon64 "${pkgdir}"/usr/bin/ucon64
+ install -Dm755 libdiscmage/discmage.so "${pkgdir}"/usr/lib/discmage.so
}
diff --git a/patch-backup-lynxit.c b/patch-backup-lynxit.c
deleted file mode 100644
index e436023df313..000000000000
--- a/patch-backup-lynxit.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- backup/lynxit.c.orig 2013-02-24 18:40:11.525942823 -0800
-+++ backup/lynxit.c 2013-02-24 18:46:25.101942911 -0800
-@@ -561,7 +561,7 @@
- return FALSE;
- }
-
-- if (strcmp (header.magic, "LYNX") != 0)
-+ if (memcmp (header.magic, "LYNX", sizeof(header.magic)) != 0)
- {
- MESSAGE (("ERROR : %s is not a lynx image\n", filename));
- fclose (fp);
-@@ -682,7 +682,7 @@
- #endif
-
- memset (&header, 0, sizeof (st_lnx_header_t));
-- strcpy (header.magic, MAGIC_STRING);
-+ memcpy (header.magic, MAGIC_STRING, sizeof(header.magic));
- strcpy (header.cartname, cartname);
- strcpy (header.manufname, manufname);
- header.page_size_bank0 = cart_analyse (BANK0);
diff --git a/patch-libdiscimage-misc_z.c b/patch-libdiscimage-misc_z.c
deleted file mode 100644
index b7e80e85ac12..000000000000
--- a/patch-libdiscimage-misc_z.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libdiscmage/misc_z.c.orig 2013-02-24 18:50:29.788944291 -0800
-+++ libdiscmage/misc_z.c 2013-02-24 18:51:00.403942771 -0800
-@@ -27,6 +27,7 @@
- #include <string.h>
- #include <errno.h>
- #include <sys/stat.h>
-+#define Z_SOLO
- #include <zlib.h>
- #include "misc_z.h"
- #include "misc.h"
diff --git a/patch-libdiscimage-unzip.h b/patch-libdiscimage-unzip.h
deleted file mode 100644
index 81d26859cd89..000000000000
--- a/patch-libdiscimage-unzip.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- libdiscmage/unzip.h.orig 2013-02-24 18:48:58.073946338 -0800
-+++ libdiscmage/unzip.h 2013-02-24 18:50:15.451943149 -0800
-@@ -49,6 +49,10 @@
- #include "zlib.h"
- #endif
-
-+#ifndef OF
-+#define OF(x) x
-+#endif
-+
- #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
- /* like the STRICT of WIN32, we define a pointer that cannot be converted
- from (void*) without cast */
diff --git a/patch-misc-archive.c b/patch-misc-archive.c
deleted file mode 100644
index a9c5776aae9d..000000000000
--- a/patch-misc-archive.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- misc/archive.c.orig 2013-02-24 18:51:23.157943222 -0800
-+++ misc/archive.c 2013-02-24 18:55:00.666943043 -0800
-@@ -27,6 +27,7 @@
- #include <string.h>
- #include <errno.h>
- #include <sys/stat.h>
-+#define Z_SOLO
- #include <zlib.h>
- #ifdef HAVE_BYTESWAP_H
- #include <byteswap.h>
diff --git a/patch-misc-unzip.h b/patch-misc-unzip.h
deleted file mode 100644
index cc99ae29d53e..000000000000
--- a/patch-misc-unzip.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- misc/unzip.h.orig 2013-02-24 18:47:37.112077049 -0800
-+++ misc/unzip.h 2013-02-24 18:48:46.040942781 -0800
-@@ -49,6 +49,10 @@
- #include "zlib.h"
- #endif
-
-+#ifndef OF
-+#define OF(x) x
-+#endif
-+
- #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
- /* like the STRICT of WIN32, we define a pointer that cannot be converted
- from (void*) without cast */
diff --git a/patch-ucon64.c b/patch-ucon64.c
deleted file mode 100644
index 12b0fa6c12a9..000000000000
--- a/patch-ucon64.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- ucon64.c.orig 2005-01-06 15:43:44.000000000 -0800
-+++ ucon64.c 2013-02-24 23:25:47.094966291 -0800
-@@ -1394,17 +1394,7 @@
- #ifdef DLOPEN
- ucon64.discmage_path;
- #else
--#if defined __MSDOS__
-- "discmage.dxe";
--#elif defined __CYGWIN__ || defined _WIN32
-- "discmage.dll";
--#elif defined __APPLE__ // Mac OS X actually
-- "libdiscmage.dylib";
--#elif defined __unix__ || defined __BEOS__
-- "libdiscmage.so";
--#else
-- "unknown";
--#endif
-+ "%%PREFIX%%/lib/libdiscmage.so";
- #endif
-
- if (!ucon64.discmage_enabled)
diff --git a/patch-ucon64_misc.c b/patch-ucon64_misc.c
index 32b4418ea19c..146801c0440a 100644
--- a/patch-ucon64_misc.c
+++ b/patch-ucon64_misc.c
@@ -1,11 +1,11 @@
---- ucon64_misc.c.orig 2013-02-24 22:48:15.577943937 -0800
-+++ ucon64_misc.c 2013-02-24 22:51:28.521008805 -0800
-@@ -1698,7 +1698,7 @@
+--- ucon64_misc.c.orig 2017-07-05 21:00:01.742106829 +0200
++++ ucon64_misc.c 2017-07-05 21:00:31.738646663 +0200
+@@ -1180,7 +1180,7 @@
#elif defined __APPLE__ // Mac OS X actually
- "~/.ucon64/discmage.dylib",
+ PROPERTY_MODE_DIR ("ucon64") "discmage.dylib",
#elif defined __unix__ || defined __BEOS__
-- "~/.ucon64/discmage.so",
-+ "%%PREFIX%%/lib/libdiscmage.so",
+- PROPERTY_MODE_DIR ("ucon64") "discmage.so",
++ "/usr/lib/discmage.so",
#else
"",
#endif