summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-29 13:23:31 +1200
committercaltlgin2020-06-29 13:23:31 +1200
commit4537544cb5a285a3d2f70fc598df6981f786671f (patch)
tree2b6aa85ef10fea27ffb90063a125dfa2e6023ac0
downloadaur-4537544cb5a285a3d2f70fc598df6981f786671f.tar.gz
Add to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--info.install8
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..612e27d3e33a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = uconv-c-git
+ pkgdesc = General unit converter for the command line
+ pkgver = 0.0.1.r6.g2173c6e
+ pkgrel = 1
+ url = https://github.com/kevinboone/uconv
+ install = info.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ provides = uconv-c
+ conflicts = uconv-c
+ source = git+https://github.com/kevinboone/uconv.git
+ sha256sums = SKIP
+
+pkgname = uconv-c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8086210fd83a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+# To avoid conflict with uconv from https://www.archlinux.org/packages/core/x86_64/icu/
+# uconv will be installed with the name of uconv-c
+_pkgname=uconv
+__pkgname=${_pkgname}-c
+pkgname=${__pkgname}-git
+
+pkgver=0.0.1.r6.g2173c6e
+pkgrel=1
+pkgdesc='General unit converter for the command line'
+arch=('x86_64' 'i686')
+url='https://github.com/kevinboone/uconv'
+license=('GPL3')
+provides=("${__pkgname}")
+conflicts=("${__pkgname}")
+install='info.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ make -C "${_pkgname}"
+}
+
+package() {
+ install -Dm755 "${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${__pkgname}"
+ install -Dm644 "${_pkgname}/man1/${_pkgname}.1" "${pkgdir}/usr/share/man/man1/${__pkgname}.1"
+ install -Dm644 "${_pkgname}/README.md" "${pkgdir}/usr/share/doc/${__pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/info.install b/info.install
new file mode 100644
index 000000000000..d9d2deed4fbd
--- /dev/null
+++ b/info.install
@@ -0,0 +1,8 @@
+post_install() {
+ cat << EOF
+
+==> To avoid conflict with uconv from https://www.archlinux.org/packages/core/x86_64/icu/
+==> uconv has been installed with the name of uconv-c
+
+EOF
+}