summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlyxia Sother2023-09-10 21:39:17 +0200
committerAlyxia Sother2023-09-10 21:39:17 +0200
commit9267ebee6b84c812cce91cb775bdf783569567ac (patch)
treedcbcf50fa3922c9be854f0842a6009da7776657b
downloadaur-9267ebee6b84c812cce91cb775bdf783569567ac.tar.gz
[Meta] Initial publish
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
-rw-r--r--ucspi-tcp.patch25
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c1dafc7773
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ucspi-tcp
+ pkgdesc = Easy-to-use command-line tools for building TCP client-server applications.
+ pkgver = 0.88
+ pkgrel = 1
+ url = http://cr.yp.to/ucspi-tcp.html
+ arch = x86_64
+ arch = aarch64
+ license = unknown
+ provides = tcpserver
+ provides = tcpclient
+ source = http://cr.yp.to/ucspi-tcp/ucspi-tcp-0.88.tar.gz
+ source = ucspi-tcp.patch
+ sha256sums = 4a0615cab74886f5b4f7e8fd32933a07b955536a3476d74ea087a3ea66a23e9c
+ sha256sums = 9d599c6362a4fab5335c5ee90b3c2a9ffe6dff30b3e15a3516e8dbcc6bc289f2
+
+pkgname = ucspi-tcp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3427644fa4f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alyxia Sother <nylkvn@evfrhc.arg(rot13)>
+
+pkgname=ucspi-tcp
+pkgver=0.88
+pkgrel=1
+pkgdesc="Easy-to-use command-line tools for building TCP client-server applications."
+arch=('x86_64' 'aarch64')
+provides=('tcpserver' 'tcpclient')
+url="http://cr.yp.to/ucspi-tcp.html"
+license=('unknown')
+
+source=("http://cr.yp.to/ucspi-tcp/ucspi-tcp-0.88.tar.gz"
+ "ucspi-tcp.patch")
+sha256sums=('4a0615cab74886f5b4f7e8fd32933a07b955536a3476d74ea087a3ea66a23e9c'
+ '9d599c6362a4fab5335c5ee90b3c2a9ffe6dff30b3e15a3516e8dbcc6bc289f2')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Changes the types of two conflicting function definitions and adds compiler
+ # flags to the Makefile.
+ patch --strip=1 --input="$srcdir/$pkgname.patch"
+
+ # The package, being written in the year 2000, thus being arcane ancient C,
+ # uses some insane method for automatically generating a source file that
+ # contains the folder we're installing to. Luckily this can be controlled by
+ # a simple text file.
+ echo "$pkgdir/usr/local" >| conf-home
+}
+
+package() {
+ # I believe referencing pkgdir within the package step is some heinous act? I
+ # don't have a choice though. Putting this in the prepare step causes an
+ # error during compilation. The build step doesn't work either.
+ mkdir -p "$pkgdir/usr/local"
+
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ make setup check
+}
diff --git a/ucspi-tcp.patch b/ucspi-tcp.patch
new file mode 100644
index 000000000000..63118135eb27
--- /dev/null
+++ b/ucspi-tcp.patch
@@ -0,0 +1,25 @@
+diff --color '--color=auto' --unified --unified --recursive --text ucspi-tcp-0.88/Makefile patch/Makefile
+--- ucspi-tcp-0.88/Makefile 2000-03-18 16:18:42.000000000 +0100
++++ patch/Makefile 2023-09-10 13:51:54.334623523 +0200
+@@ -159,7 +159,7 @@
+ compile: \
+ warn-auto.sh conf-cc
+ ( cat warn-auto.sh; \
+- echo exec "`head -1 conf-cc`" '-c $${1+"$$@"}' \
++ echo exec "`head -1 conf-cc`" '-include errno.h' '-include unistd.h' '-c $${1+"$$@"}' \
+ ) > compile
+ chmod 755 compile
+
+diff --color '--color=auto' --unified --unified --recursive --text ucspi-tcp-0.88/readwrite.h patch/readwrite.h
+--- ucspi-tcp-0.88/readwrite.h 2000-03-18 16:18:42.000000000 +0100
++++ patch/readwrite.h 2023-09-10 13:53:10.657846842 +0200
+@@ -1,7 +1,7 @@
+ #ifndef READWRITE_H
+ #define READWRITE_H
+
+-extern int read();
+-extern int write();
++extern ssize_t read();
++extern ssize_t write();
+
+ #endif