summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten van Gompel2015-06-21 12:51:52 +0200
committerMaarten van Gompel2015-06-21 12:51:52 +0200
commit0e8479cdfcfcfd4fb45e6e7d666a049ebf56ea02 (patch)
treeae375947ce2ff0e0821eb202f2f403486d2ea286
downloadaur-0e8479cdfcfcfd4fb45e6e7d666a049ebf56ea02.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9817a8498789
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ucto
+ pkgdesc = An advanced rule-based (regular-expression) and unicode-aware tokenizer for various languages. Tokenization is an essential first step in any NLP pipeline.
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://ilk.uvt.nl/ucto
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = libtool
+ makedepends = autoconf
+ depends = ticcutils>=0.7
+ depends = icu
+ depends = libxml2
+ depends = libfolia>=0.13
+ options = !libtool
+ source = http://software.ticc.uvt.nl/ucto-0.8.0.tar.gz
+ md5sums = 67750bc54be80bdc9bb47acf8e5aa616
+
+pkgname = ucto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6e8997fe74a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy dot nl>
+pkgname=ucto
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="An advanced rule-based (regular-expression) and unicode-aware tokenizer for various languages. Tokenization is an essential first step in any NLP pipeline."
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('ticcutils>=0.7' 'icu' 'libxml2' 'libfolia>=0.13')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+url="http://ilk.uvt.nl/ucto"
+source=("http://software.ticc.uvt.nl/$pkgname-$pkgver.tar.gz")
+md5sums=('67750bc54be80bdc9bb47acf8e5aa616')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}