summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:07:16 +0200
committersl1pkn072015-06-08 20:07:16 +0200
commit08e4c561a89ca2492cf29d8ac376f5c6c748d680 (patch)
treeb290635e04c927c6307bd3709e4c911992c05a36
downloadaur-08e4c561a89ca2492cf29d8ac376f5c6c748d680.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c29b99f1dcb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = udev-notify-bzr
+ pkgdesc = Visual hardware notifications for Linux. (Bazaar version)
+ pkgver = 32
+ pkgrel = 1
+ url = https://launchpad.net/udev-notify
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ depends = notification-daemon
+ depends = python2
+ depends = python2-udev
+ depends = python2-notify
+ provides = udev-notify
+ conflicts = udev-notify
+ source = udev-notify::bzr+lp:udev-notify
+ sha1sums = SKIP
+
+pkgname = udev-notify-bzr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d38705b463f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Alexander De Sousa <archaur.xandy21@spamgourmet.com>
+
+pkgname=udev-notify-bzr
+pkgver=32
+pkgrel=1
+pkgdesc="Visual hardware notifications for Linux. (Bazaar version)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/udev-notify"
+license=('GPL3')
+depends=('notification-daemon' 'python2' 'python2-udev' 'python2-notify')
+makedepends=('bzr')
+conflicts=('udev-notify')
+provides=('udev-notify')
+source=('udev-notify::bzr+lp:udev-notify')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd udev-notify
+ echo "$(bzr revno)"
+}
+
+prepare() {
+ # Prepare Makefile
+ sed -e 11d -e '/debian-package.sh/d' -e '/pyudev/d' -e 's|\./build/debian|$(DESTDIR)|g' -i udev-notify/Makefile
+ # Force use python2
+ sed 's|env python|env python2|g' -i udev-notify/src/udev-notify.py
+}
+
+package() {
+ make -C udev-notify DESTDIR="${pkgdir}"
+}