summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVHSgunzo2022-07-10 22:11:31 +0300
committerVHSgunzo2022-07-10 22:11:31 +0300
commitba9bf2e39e7da8ca210df126c0172c6bc9a5a84e (patch)
treec23bfd1b380959081859e864fc3087d86ae31fe6
downloadaur-ba9bf2e39e7da8ca210df126c0172c6bc9a5a84e.tar.gz
udev-notify v0.1.r0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d22e1e2dce27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = udev-notify-git
+ pkgdesc = Show notifications when any USB device is plugged/unplugged
+ pkgver = 0.1.r0.gc19e2fa
+ pkgrel = 1
+ url = https://github.com/VHSgunzo/udev-notify
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = libnotify
+ depends = sox
+ optdepends = espeak-ng
+ provides = udev-notify
+ conflicts = udev-notify
+ source = git+https://github.com/VHSgunzo/udev-notify.git
+ sha256sums = SKIP
+
+pkgname = udev-notify-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad8721050d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: VHSgunzo <vhsgunzo.github.io>
+pkgname=udev-notify-git
+pkgver=0.1.r0.gc19e2fa
+pkgrel=1
+pkgdesc='Show notifications when any USB device is plugged/unplugged'
+arch=('any')
+url='https://github.com/VHSgunzo/udev-notify'
+license=('MIT')
+depends=('libnotify' 'sox')
+makedepends=('git')
+optdepends=('espeak-ng')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/VHSgunzo/udev-notify.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $srcdir/${pkgname%-git}
+ make DESTDIR="${pkgdir}" install
+}