summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni2017-04-13 00:07:57 -0300
committerRoger Zanoni2017-04-13 00:07:57 -0300
commite09886dbd9eecc9c6bb1d0058699998a7d6cc349 (patch)
tree66ea21d31da610237d7cc3345643c54995b99a86
downloadaur-e09886dbd9eecc9c6bb1d0058699998a7d6cc349.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f121c77063c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = udevnotifier-git
+ pkgdesc = A Qt handler library for UDEV event system notifications
+ pkgver = 7149ecd
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = qt5-base
+ depends = libsystemd
+ source = udevnotifier-git::git+https://github.com/rogerzanoni/udevnotifier.git
+ sha256sums = SKIP
+
+pkgname = udevnotifier-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb1a65930632
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Roger Zanoni <rogerzanoni@gmail.com>
+
+pkgname=udevnotifier-git
+pkgver=7149ecd
+pkgrel=1
+pkgdesc="A Qt handler library for UDEV event system notifications"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('qt5-base' 'libsystemd')
+# temporary source, should be https://github.com/nwoki/udevnotifier.git
+source=("$pkgname::git+https://github.com/rogerzanoni/udevnotifier.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ qmake .
+ make
+}
+
+package() {
+ cd $pkgname
+ make INSTALL_ROOT="$pkgdir" install
+} \ No newline at end of file