summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2017-09-24 13:00:07 +0300
committerAlexey D2017-09-24 13:21:56 +0300
commit910a2690f2dc78fba0120d310804ed0cd48d0dc0 (patch)
treeb5e8e1380d8b66f28de8872b51313110da61072b
parentf357eac5f2b6239bd9eb88b556c4b73e90ae39a7 (diff)
downloadaur-910a2690f2dc78fba0120d310804ed0cd48d0dc0.tar.gz
disable systemd-login check in configure script
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--disable_logind_support.patch14
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5194a0c7e4db..e5f9e716729d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 10:10:29 UTC 2017
+# Sun Sep 24 09:59:53 UTC 2017
pkgbase = udisks2-nosystemd
pkgdesc = Disk Management Service, version 2
pkgver = 2.7.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.freedesktop.org/wiki/Software/udisks
arch = i686
arch = x86_64
@@ -33,8 +33,10 @@ pkgbase = udisks2-nosystemd
options = !libtool
source = https://github.com/storaged-project/udisks/archive/udisks-2.7.2.tar.gz
source = fix_build.patch
+ source = disable_logind_support.patch
sha256sums = 34d834520efcfbb8cca33ccf703e45752b32772ae766673dab6360202c7838aa
sha256sums = 9b9144de4d68703f574987d36dbe08c3b97d525adea65870f9b940f3315eefe7
+ sha256sums = 202daeb2a924b0c0c2bfaef0f09a2b0d43bd9c46d1b61f42342162690cf62560
pkgname = udisks2-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index 4c976e3abc77..1051d6ce116f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=udisks2-nosystemd
pkgver=2.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="Disk Management Service, version 2"
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/udisks"
@@ -23,9 +23,11 @@ conflicts=('udisks2' 'udisks2-eudev')
replaces=('udisks2' 'udisks2-eudev')
options=(!libtool)
source=(https://github.com/storaged-project/udisks/archive/udisks-$pkgver.tar.gz
- fix_build.patch)
+ fix_build.patch
+ disable_logind_support.patch)
sha256sums=('34d834520efcfbb8cca33ccf703e45752b32772ae766673dab6360202c7838aa'
- '9b9144de4d68703f574987d36dbe08c3b97d525adea65870f9b940f3315eefe7')
+ '9b9144de4d68703f574987d36dbe08c3b97d525adea65870f9b940f3315eefe7'
+ '202daeb2a924b0c0c2bfaef0f09a2b0d43bd9c46d1b61f42342162690cf62560')
prepare() {
cd "udisks-udisks-$pkgver"
@@ -36,6 +38,11 @@ prepare() {
# Fix build with gtk-doc 2.16. See https://github.com/storaged-project/udisks/issues/389
patch -p1 -i "$srcdir"/fix_build.patch
+
+ # It should fix an issue when udisks is asking to enter an user password on
+ # every (un)mount operation if installed together with systemd package and any
+ # initsystem which supports tmpfiles.d configs.
+ patch -p1 -i "$srcdir"/disable_logind_support.patch
}
build() {
diff --git a/disable_logind_support.patch b/disable_logind_support.patch
new file mode 100644
index 000000000000..76fbd3174c80
--- /dev/null
+++ b/disable_logind_support.patch
@@ -0,0 +1,14 @@
+--- udisks-udisks-2.7.2_orig/configure.ac 2017-09-11 18:28:05.242977535 +0300
++++ udisks-udisks-2.7.2/configure.ac 2017-09-09 20:45:08.274150812 +0300
+@@ -170,10 +170,7 @@
+ AC_SUBST(LIBATASMART_CFLAGS)
+ AC_SUBST(LIBATASMART_LIBS)
+
+-PKG_CHECK_MODULES(LIBSYSTEMD_LOGIN, [libsystemd >= 209], [have_libsystemd_login=yes],
+- [PKG_CHECK_MODULES(LIBSYSTEMD_LOGIN, [libsystemd-login >= 44 libsystemd-daemon],
+- [have_libsystemd_login=yes],
+- [have_libsystemd_login=no])])
++have_libsystemd_login=no
+ AM_CONDITIONAL(HAVE_LIBSYSTEMD_LOGIN, test x$have_libsystemd_login = xyes)
+ if test "x$have_libsystemd_login" = "xyes"; then
+ AC_DEFINE([HAVE_LIBSYSTEMD_LOGIN], 1, [Define to 1 if libsystemd-login is available])