summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2023-07-10 14:24:17 +0200
committerChristian Hesse2023-07-10 14:24:17 +0200
commit46c7c7558e688c11e29b0e218a89e6945c84e582 (patch)
tree2f8edcfa8569d17b9fdffcf6d7922c12de85b043
parentb11bff2b041d1a99667e3659e1f95cd7403f685f (diff)
downloadaur-46c7c7558e688c11e29b0e218a89e6945c84e582.tar.gz
commit udpcast 20230319-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2d33dd4fa7b..20a7414c8bda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = udpcast
pkgdesc = Network multicasting tool
- pkgver = 20200328
- pkgrel = 2
- url = http://udpcast.linux.lu/
+ pkgver = 20230319
+ pkgrel = 1
+ url = https://udpcast.linux.lu/
arch = i686
arch = x86_64
license = GPL
- source = http://udpcast.linux.lu/download/udpcast-20200328.tar.gz
- sha256sums = 9c19eebaa6e2f78127f0d59e95d0ce003b687d61e283b5963a1da6b8ac41f21a
+ source = https://udpcast.linux.lu/download/udpcast-20230319.tar.gz
+ sha256sums = d96e6e455fce0a8706bbebdea41d0c7ad910ab5901293ff74d2d8ce27302e662
pkgname = udpcast
-
diff --git a/PKGBUILD b/PKGBUILD
index f0b0c93b65a4..c68a2ce17143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=udpcast
-pkgver=20200328
-pkgrel=2
-pkgdesc="Network multicasting tool"
+pkgver=20230319
+pkgrel=1
+pkgdesc='Network multicasting tool'
arch=('i686' 'x86_64')
-url="http://udpcast.linux.lu/"
+url='https://udpcast.linux.lu/'
license=('GPL')
-source=("http://udpcast.linux.lu/download/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9c19eebaa6e2f78127f0d59e95d0ce003b687d61e283b5963a1da6b8ac41f21a')
+source=("https://udpcast.linux.lu/download/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('d96e6e455fce0a8706bbebdea41d0c7ad910ab5901293ff74d2d8ce27302e662')
-build() {
+prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # install to /usr/bin
+ # sbindir is ignored - install to /usr/bin
sed -i 's/sbin/bin/g' Makefile.in
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr
make
}