summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-06 13:14:48 +0300
committerDimitris Kiziridis2020-05-06 13:14:48 +0300
commitb52a41c5ed2c4427d72c5df359ff9eedb9d79827 (patch)
treeb3552c0a0a6a76e2cbe1d60d24bf56f14dc88c0d
downloadaur-b52a41c5ed2c4427d72c5df359ff9eedb9d79827.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD20
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71d6ed89b2cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = udpreplay-bin
+ pkgdesc = Replay UDP packets from a pcap file
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/rigtorp/udpreplay
+ arch = x86_64
+ license = MIT
+ options = !strip
+ source = udpreplay-bin-1.0.0::https://github.com/rigtorp/udpreplay/releases/download/v1.0.0/udpreplay-x64-linux-static
+ source = https://raw.githubusercontent.com/rigtorp/udpreplay/master/LICENSE
+ sha256sums = 21d759bc1baee2d23ec7116c274b7f31b819f1d6f16e048f1dc75bb1c3b2f06f
+ sha256sums = df0e31127f0e68b94da98960cbfafdbfbb3b79638cf483bf833256b216921dd3
+
+pkgname = udpreplay-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..0c1b0c90b4d8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2020 Erik Rigtorp <erik@rigtorp.se>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aee3f5c62e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=udpreplay-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Replay UDP packets from a pcap file'
+arch=('x86_64')
+url='https://github.com/rigtorp/udpreplay'
+license=('MIT')
+options=('!strip')
+source=("${pkgname}-${pkgver}::https://github.com/rigtorp/udpreplay/releases/download/v${pkgver}/udpreplay-x64-linux-static"
+ 'https://raw.githubusercontent.com/rigtorp/udpreplay/master/LICENSE')
+sha256sums=('21d759bc1baee2d23ec7116c274b7f31b819f1d6f16e048f1dc75bb1c3b2f06f'
+ 'df0e31127f0e68b94da98960cbfafdbfbb3b79638cf483bf833256b216921dd3')
+
+package() {
+ install -Dm755 udpreplay* "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file