summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2023-03-24 19:55:00 -0500
committerJustKidding2023-03-24 19:55:00 -0500
commit882b4be1e04b023996222adebf0a2a4e06dcb556 (patch)
treec56cc8fb0c3c6d3befedc238a24ba6848af1f1b6
parent1b6fe2fb60edb6f9661a4e66db486f587dec9a05 (diff)
downloadaur-882b4be1e04b023996222adebf0a2a4e06dcb556.tar.gz
upgpkg: ueberzugpp 2.7.3-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c96f9bc438c..d16c413fe58f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ueberzugpp
pkgdesc = Command line util which allows to display images in combination with X11 written in C++
- pkgver = 2.7.2
+ pkgver = 2.7.3
pkgrel = 1
url = https://github.com/jstkdng/ueberzugpp
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = ueberzugpp
depends = fmt
provides = ueberzug
conflicts = ueberzug
- source = https://github.com/jstkdng/ueberzugpp/archive/v2.7.2.tar.gz
- sha256sums = 5e32db42458b4e0b0e292d8522fa7ae20d5404d89b6724ba051449e22c203fb9
+ source = https://github.com/jstkdng/ueberzugpp/archive/v2.7.3.tar.gz
+ sha256sums = 23475c7ce99aa43799904db3f589035dbf45b4fd2505854fbf51b152fe64d223
pkgname = ueberzugpp
diff --git a/PKGBUILD b/PKGBUILD
index 10a2defd2d0f..0d98ccb1e3ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=ueberzugpp
-pkgver=2.7.2
+pkgver=2.7.3
pkgrel=1
pkgdesc="Command line util which allows to display images in combination with X11 written in C++"
arch=("x86_64")
@@ -8,20 +8,20 @@ license=("GPL3")
makedepends=("cmake" "cli11")
depends=("opencv" "libvips" "xcb-util-image" "nlohmann-json" "libsixel" "openssl" "spdlog" "zeromq" "fmt")
source=("https://github.com/jstkdng/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('5e32db42458b4e0b0e292d8522fa7ae20d5404d89b6724ba051449e22c203fb9')
+sha256sums=('23475c7ce99aa43799904db3f589035dbf45b4fd2505854fbf51b152fe64d223')
provides=("ueberzug")
conflicts=("ueberzug")
build() {
cmake -B build -S "$pkgname-$pkgver" \
- -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
cmake --build build -j $(nproc)
}
package() {
- DESTDIR="$pkgdir" cmake --install build --config Release
+ DESTDIR="$pkgdir" cmake --install build
ln -s "/usr/bin/ueberzug" "$pkgdir/usr/bin/ueberzugpp"
}