summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2014-05-16 22:10:40 -0400
committerKeshav Amburay2014-05-16 22:10:40 -0400
commit722a2afab89cc429e385dd1e89ee9cda35d0cd16 (patch)
tree33e049fa38e3a88bf986ae91e32c7d276cbfc5c3
parent91187ef911826e972996b082e64fbdc24d85f959 (diff)
downloadaur-722a2afab89cc429e385dd1e89ee9cda35d0cd16.tar.gz
Add -maccumulate-outgoing-args
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14baeb868128..a82df964a4e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -100,8 +100,8 @@ _prepare_tianocore_sources() {
sed 's| -m64 -melf_x86_64| -m64|g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
msg "Remove GCC -g debug option and add -0s -mabi=ms"
- sed 's|DEFINE GCC_ALL_CC_FLAGS = -g |DEFINE GCC_ALL_CC_FLAGS = -O0 -mabi=ms |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
- sed 's|DEFINE GCC44_ALL_CC_FLAGS = -g |DEFINE GCC44_ALL_CC_FLAGS = -O0 -mabi=ms |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
+ sed 's|DEFINE GCC_ALL_CC_FLAGS = -g |DEFINE GCC_ALL_CC_FLAGS = -O0 -mabi=ms -maccumulate-outgoing-args |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
+ sed 's|DEFINE GCC44_ALL_CC_FLAGS = -g |DEFINE GCC44_ALL_CC_FLAGS = -O0 -mabi=ms -maccumulate-outgoing-args |g' -i "${EDK_TOOLS_PATH}/Conf/tools_def.template" || true
msg "Fix UDK Target Platform"
sed "s|ACTIVE_PLATFORM = Nt32Pkg/Nt32Pkg.dsc|ACTIVE_PLATFORM = ${_UDK_TARGET}|g" -i "${EDK_TOOLS_PATH}/Conf/target.template" || true