summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2018-06-01 01:14:55 +0200
committerxsmile2018-06-01 01:14:55 +0200
commit9a28afea7600b6bf482caa0021d21d610f5bebae (patch)
tree192abcf785f8500b8ea2c708485e39f721bb2325
parent8a5dc7a473dc3b8127d5f968c0397f6d651ac22d (diff)
downloadaur-9a28afea7600b6bf482caa0021d21d610f5bebae.tar.gz
Removed UEFIExtract,UEFIFind and uefipatch.cpp.patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
-rw-r--r--uefipatch.cpp.patch18
3 files changed, 10 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54e2de708117..e39ecdd61ad0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Sep 13 10:10:21 UTC 2017
pkgbase = uefitool-git
pkgdesc = UEFI firmware image viewer and editor and utilities
- pkgver = r171.75225ec
- pkgrel = 2
+ pkgver = r210.997c007
+ pkgrel = 1
url = https://github.com/LongSoft/UEFITool
arch = any
license = BSD
@@ -13,9 +11,7 @@ pkgbase = uefitool-git
provides = uefitool
conflicts = uefitool
source = uefitool::git+https://github.com/LongSoft/UEFITool.git
- source = uefipatch.cpp.patch
md5sums = SKIP
- md5sums = 5c2df7cd74307fa46c13cd10159951da
pkgname = uefitool-git
diff --git a/PKGBUILD b/PKGBUILD
index d5695af92b26..3dfdd1bd8ebd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,25 @@
pkgname=uefitool-git
_pkgname=uefitool
-_tools=('UEFIExtract' 'UEFIFind' 'UEFIPatch' 'UEFIReplace')
-pkgver=r171.75225ec
-pkgrel=2
+_tools=('UEFIPatch' 'UEFIReplace')
+pkgver=r210.997c007
+pkgrel=1
pkgdesc='UEFI firmware image viewer and editor and utilities'
arch=('any')
url='https://github.com/LongSoft/UEFITool'
license=('BSD')
depends=('qt5-base')
makedepends=('git' 'qt5-base')
-provides=(${_pkgname})
-conflicts=(${_pkgname})
-source=("${_pkgname}::git+${url}.git"
- 'uefipatch.cpp.patch')
-md5sums=('SKIP'
- '5c2df7cd74307fa46c13cd10159951da')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- # pre-set the path to patches.txt in UEFIPatch
- patch -p1 -i "$srcdir/uefipatch.cpp.patch"
-}
-
_build() {
qmake QMAKE_CFLAGS_RELEASE="$CFLAGS" QMAKE_CXXFLAGS_RELEASE="$CXXFLAGS"
make
@@ -52,7 +45,7 @@ package() {
for tool in "${_tools[@]}"; do
install -D -m755 "$tool/$tool" "$pkgdir/usr/bin/${tool,,}"
done
- # Install patches.txt to pre-set path
+ # Install patches.txt
install -D -m644 UEFIPatch/patches.txt "$pkgdir/usr/share/$_pkgname/patches.txt"
# License
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
diff --git a/uefipatch.cpp.patch b/uefipatch.cpp.patch
deleted file mode 100644
index 7bd86073ea84..000000000000
--- a/uefipatch.cpp.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/uefitool/UEFIPatch/uefipatch.cpp 2016-10-07 23:39:16.579188249 +0200
-+++ b/uefitool/UEFIPatch/uefipatch.cpp 2016-10-07 23:40:00.707034736 +0200
-@@ -27,13 +27,13 @@
-
- UINT8 UEFIPatch::patchFromFile(QString path)
- {
-- QFileInfo patchInfo = QFileInfo("patches.txt");
-+ QFileInfo patchInfo = QFileInfo("/usr/share/uefitool/patches.txt");
-
- if (!patchInfo.exists())
- return ERR_INVALID_FILE;
-
- QFile file;
-- file.setFileName("patches.txt");
-+ file.setFileName("/usr/share/uefitool/patches.txt");
-
- if (!file.open(QFile::ReadOnly | QFile::Text))
- return ERR_INVALID_FILE;