summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2018-08-03 09:57:54 +0300
committerCaleb Maclennan2018-08-03 09:57:54 +0300
commit8369d95a3468b955ed2cf1c7d6b1cdb6ea4d4154 (patch)
treef2e82359780cb87c04e1dccc28ee62968af07e61
downloadaur-8369d95a3468b955ed2cf1c7d6b1cdb6ea4d4154.tar.gz
Initial commit stable branch adapted from -git package
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
-rw-r--r--python3.patch47
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6b74789c77d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Aug 3 06:57:39 UTC 2018
+pkgbase = ufo2otf
+ pkgdesc = Tools for converting Bibles from USFM to OSIS XML
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/chrislit/usfm2osis
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = fontforge
+ depends = afdko
+ conflicts = ufo2otf-git
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/u/ufo2otf/ufo2otf-0.2.2.tar.gz
+ source = python3.patch
+ sha256sums = 180b4e1bbacb5f94338e87c160bf68a0919956c0e31310ad0195d0e6c25d96ca
+ sha256sums = 152396362fb91765a7a34958d24ca521a804df3ade5f0cce27135dfb1c712d62
+
+pkgname = ufo2otf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3ea67f2cb7b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+!.SRCINFO
+!.gitignore
+!PKGBUILD
+!*.patch
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c6f53ddd908
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=ufo2otf
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Tools for converting Bibles from USFM to OSIS XML"
+arch=('any')
+url="https://github.com/chrislit/usfm2osis"
+license=('BSD')
+conflicts=("${pkgname}-git")
+depends=('python'
+ 'fontforge'
+ 'afdko')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/u/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'python3.patch')
+sha256sums=('180b4e1bbacb5f94338e87c160bf68a0919956c0e31310ad0195d0e6c25d96ca'
+ '152396362fb91765a7a34958d24ca521a804df3ade5f0cce27135dfb1c712d62')
+
+prepare () {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 < ${srcdir}/python3.patch
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py -q install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/python3.patch b/python3.patch
new file mode 100644
index 000000000000..81cf0126b361
--- /dev/null
+++ b/python3.patch
@@ -0,0 +1,47 @@
+diff --git a/bin/ufo2otf b/bin/ufo2otf
+index fdfa2e6..bfbd9ca 100644
+--- a/bin/ufo2otf
++++ b/bin/ufo2otf
+@@ -25,7 +25,7 @@ from ufo2otf import FontError
+
+ def diagnostics():
+ e = FontError()
+- print e
++ print(e)
+
+ def console():
+ from sys import exit
+diff --git a/ufo2otf/__init__.py b/ufo2otf/__init__.py
+index 65f245e..7ade949 100644
+--- a/ufo2otf/__init__.py
++++ b/ufo2otf/__init__.py
+@@ -1,3 +1,3 @@
+ import argparse
+-from compilers import Compiler
+-from diagnostics import diagnostics, FontError
++from .compilers import Compiler
++from .diagnostics import diagnostics, FontError
+diff --git a/ufo2otf/compilers.py b/ufo2otf/compilers.py
+index 2014bfd..f012639 100644
+--- a/ufo2otf/compilers.py
++++ b/ufo2otf/compilers.py
+@@ -4,7 +4,7 @@
+ from os import mkdir
+ from os.path import splitext, dirname, sep, join, exists, basename
+ from subprocess import Popen
+-from diagnostics import diagnostics, known_compilers, FontError
++from .diagnostics import diagnostics, known_compilers, FontError
+ import codecs
+ import re
+
+diff --git a/ufo2otf/diagnostics.py b/ufo2otf/diagnostics.py
+index 2271af2..eff7316 100644
+--- a/ufo2otf/diagnostics.py
++++ b/ufo2otf/diagnostics.py
+@@ -158,5 +158,5 @@ class FontError(Exception):
+ if __name__ == "__main__":
+ # This will print diagnostics to stdout
+ e = FontError()
+- print e
++ print(e)
+