summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 21:32:18 +0300
committerCaleb Maclennan2023-05-03 21:32:18 +0300
commit9d760f8b471abd8d0c6b22c6b2696d534dd643ca (patch)
tree1cebe265d7963632acbde1f2850667e1ca9ed837
parentd0ec9a80237d09ab83b3b2186a812a231e32ffae (diff)
downloadaur-9d760f8b471abd8d0c6b22c6b2696d534dd643ca.tar.gz
upgpkg: ufo2otf 0.2.2-2
Rebuild for Python 3.11, normalize PEP517 build tooling
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb28bf28dfc3..5db24cee0a65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,9 @@ pkgbase = ufo2otf
url = https://github.com/fonts/ufo2otf
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = fontforge
diff --git a/PKGBUILD b/PKGBUILD
index 9288f897e2cc..0884b1283e27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,8 @@ license=(BSD)
depends=(python
fontforge
afdko)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
options=(!emptydirs)
_archive="$pkgname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_archive.tar.gz"
@@ -25,11 +26,11 @@ prepare () {
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
}