summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNebulaBC2023-10-12 22:37:13 -0400
committerNebulaBC2023-10-12 22:37:13 -0400
commitb208c7334107707b5b13c8e9a3c1a3823d7fa346 (patch)
treed3a1567725113fd950be5ae88a2662e8b195bbfb
parent75d4799721feb3894ffb7b041394ce71ee70e903 (diff)
downloadaur-b208c7334107707b5b13c8e9a3c1a3823d7fa346.tar.gz
Update to 1.1. Fix outdated dependency and clean up PKGBUILD
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee4c425bd3af..9b5f0cb363f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: NebulaBC <ufrii.print@nebulabc.net>
pkgname='ufrii-print'
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Install the official Canon UFRII/UFRII LT driver made for Debian on ArchLinux"
url="https://www.usa.canon.com/support/p/color-imageclass-mf644cdw"
@@ -10,14 +10,16 @@ depends=('cups'
'gtk3'
'libjpeg6-turbo'
'libgcrypt'
- 'libjbig-shared'
- 'zlib'
- 'wget')
+ 'jbigkit'
+ 'zlib')
install=install.sh
+source=("https://gdlp01.c-wss.com/gds/6/0100009236/15/linux-UFRII-drv-v570-us-11.tar.gz")
+
+sha256sums=("e5afaac96abfeb13b36311ee880dcf5942155e1877f9aa36cecca29647d9a232")
+
build() {
- wget https://gdlp01.c-wss.com/gds/6/0100009236/15/linux-UFRII-drv-v570-us-11.tar.gz
tar -xf linux-UFRII-drv-v570-us-11.tar.gz
cd linux-UFRII-drv-v570-us/x64/Debian
mv cnrdrvcups-ufr2-us_5.70-1.11_amd64.deb $srcdir
@@ -31,6 +33,7 @@ build() {
package() {
cd $srcdir
- mv * $pkgdir
+ # Because this package has no sort of make system, there's no `install` command I know of that lets me copy the prepared srcdir to the pkgdir. MarsSeed flagged this package out of date because of my `mv` usage. Hopefully this should be better.
+ cp -dr --no-preserve=ownership * $pkgdir
echo "To open the setup GUI, you can run \`cnsetuputil2\`"
}