summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-16 15:19:42 +0200
committerGoliathLabs2020-05-16 15:19:42 +0200
commit5f1f5424ca5eb6177e441a2906c3cdaa05ef43e8 (patch)
tree4fd549c3ec933f86c36e68e3335d12532193b7b5
parentfa688b27c16b3be21c5be2eeb367840b02b5421e (diff)
downloadaur-5f1f5424ca5eb6177e441a2906c3cdaa05ef43e8.tar.gz
Updated: 9.6.7
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
-rw-r--r--remove-lru_cache_add_anon.patch11
3 files changed, 15 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8240cbe38c28..958f74c7d90a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ufsd-module-dkms
pkgdesc = Paragon NTFS & HFS for Linux driver. - ACLs removed. DKMS version
- pkgver = 9.0
+ pkgver = 9.6.7
pkgrel = 1
url = http://paragon-software.com/
install = ufsd-module-dkms.install
@@ -9,12 +9,11 @@ pkgbase = ufsd-module-dkms
license = custom
makedepends = linux-lts-headers
depends = dkms
- depends = linux-lts<3.16
+ depends = linux-lts
+ source = https://dl.paragon-software.com/free/Paragon-715-FRE_NTFS_Linux_9.6.7_Express.tar.gz
source = dkms.conf
- source = remove-lru_cache_add_anon.patch
- md5sums = 838702d38c5d51f14f52b2b5312e0f33
- md5sums = 22e227efcee141c8c41798b39dbb62f2
- md5sums = f874a41209d93998df1d44f60e96a7bd
+ sha256sums = bb2bd93f12b08f1e003960c45057fa9d6b2302bb40abb15b1af6767c1479a776
+ sha256sums = ccbfd0311238835fe3eff647f0196046a1557187da75f81c3ef9935c39229e13
pkgname = ufsd-module-dkms
diff --git a/PKGBUILD b/PKGBUILD
index bb8af20ab13b..1c4a42464273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,33 @@
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: Kowalczyk Patryk <patryk AT kowalczyk DOT ws>
# Contributor: <John freehaha at gmail dot com> - patch paragon-ufsd-3.10_v01.patch
# Contributor: Pradeep Murthy <pradeepmur (at) gmail> (dkms wrapper)
pkgname=ufsd-module-dkms
_pkgname=ufsd-module
-pkgver=9.0
-_srcdir=Paragon-147-FRE_NTFS_Linux_${pkgver}_Express
+pkgver=9.6.7
+_srcdir=Paragon-715-FRE_NTFS_Linux_${pkgver}_Express
pkgrel=1
pkgdesc='Paragon NTFS & HFS for Linux driver. - ACLs removed. DKMS version'
arch=('i686' 'x86_64')
url='http://paragon-software.com/'
license=('custom')
-depends=('dkms' 'linux-lts<3.16')
+depends=('dkms' 'linux-lts')
makedepends=('linux-lts-headers')
install=ufsd-module-dkms.install
-# Download the file from <http://www.paragon-software.com/home/ntfs-linux-per/download.html>
-source=("Paragon-147-FRE_NTFS_Linux_${pkgver}_Express.tar.gz"
+source=("https://dl.paragon-software.com/free/Paragon-715-FRE_NTFS_Linux_${pkgver}_Express.tar.gz"
"dkms.conf"
- "remove-lru_cache_add_anon.patch"
)
-md5sums=('838702d38c5d51f14f52b2b5312e0f33'
- '22e227efcee141c8c41798b39dbb62f2'
- 'f874a41209d93998df1d44f60e96a7bd')
+sha256sums=('bb2bd93f12b08f1e003960c45057fa9d6b2302bb40abb15b1af6767c1479a776'
+ 'ccbfd0311238835fe3eff647f0196046a1557187da75f81c3ef9935c39229e13')
-prepare() {
- cd "$_srcdir"
- patch -Np1 -i "$srcdir"/remove-lru_cache_add_anon.patch
-}
package() {
install -dm755 ${pkgdir}/usr/src/${_pkgname}-${pkgver}
sed "s/%pkgver%/$pkgver/" dkms.conf > ${pkgdir}/usr/src/${_pkgname}-${pkgver}/dkms.conf
- cp -RL ${_srcdir}/* ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -RL ${srcdir}/* ${pkgdir}/usr/src/${_pkgname}-${pkgver}
}
diff --git a/remove-lru_cache_add_anon.patch b/remove-lru_cache_add_anon.patch
deleted file mode 100644
index afd0149be43f..000000000000
--- a/remove-lru_cache_add_anon.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Paragon-147-FRE_NTFS_Linux_9.0_Express/ifslinux/ufsdvfs.c.orig 2015-09-09 00:05:01.695085717 +0200
-+++ Paragon-147-FRE_NTFS_Linux_9.0_Express/ifslinux/ufsdvfs.c 2015-09-09 00:05:21.355151784 +0200
-@@ -8235,7 +8235,7 @@
- err = err2;
- }
-
-- PageSwapBacked( page )? lru_cache_add_anon( page ) : lru_cache_add_file( page );
-+ lru_cache_add_file( page );
- }
-
- page_cache_release( page );