summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLetu Ren2024-01-09 14:14:46 +0800
committerLetu Ren2024-01-09 14:14:46 +0800
commitd0bf88b084ffd122ffede9168544a06ac5275a0c (patch)
tree6d324ca4943c5562dd21a2ae3f5dcfeaedf82b54
parent35338ffe2fe74eccd0159a6b94bd4a8df029aee6 (diff)
downloadaur-uftrace.tar.gz
update to 0.15
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f20138e8e9fb..a0c30e1554f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = uftrace
pkgdesc = Function graph tracer for C/C++/Rust
- pkgver = 0.14
+ pkgver = 0.15
pkgrel = 1
url = https://github.com/namhyung/uftrace
arch = x86_64
license = GPL2
+ makedepends = pkgconf
makedepends = pandoc
depends = libelf
depends = python
depends = ncurses
- depends = pkgconf
depends = luajit
depends = capstone
depends = libunwind
+ depends = libtraceevent
options = !lto
- source = uftrace-v0.14.tar.gz::https://github.com/namhyung/uftrace/archive/v0.14.tar.gz
- sha256sums = b81255bc288e79e96a5b158d4875fa6425ad51c85f4c4c8523c1defb9366ad12
+ source = uftrace-v0.15.tar.gz::https://github.com/namhyung/uftrace/archive/v0.15.tar.gz
+ sha256sums = c4f2a45687fd39dbde509635ebf094d7ed301793920f37bcaabb8161ff69f2fd
pkgname = uftrace
diff --git a/PKGBUILD b/PKGBUILD
index d7d795ec5543..23710e03a3d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,31 @@
# Contributor: Bumsik Kim <k.bumsik@gmail.com>
pkgname=uftrace
-pkgver=0.14
+pkgver=0.15
pkgrel=1
pkgdesc="Function graph tracer for C/C++/Rust"
arch=('x86_64')
url="https://github.com/namhyung/uftrace"
license=('GPL2')
-depends=('libelf' 'python' 'ncurses' 'pkgconf' 'luajit' 'capstone' 'libunwind')
-makedepends=('pandoc')
+depends=(
+ 'libelf'
+ 'python'
+ 'ncurses'
+ 'luajit'
+ 'capstone'
+ 'libunwind'
+ 'libtraceevent'
+)
+makedepends=(
+ 'pkgconf'
+ 'pandoc'
+)
# Disable LTO due to upstream issue
# https://github.com/namhyung/uftrace/issues/1343
options=('!lto')
source=("uftrace-v${pkgver}.tar.gz"::"https://github.com/namhyung/uftrace/archive/v${pkgver}.tar.gz")
# Use updpkgsums to update the checksum
-sha256sums=('b81255bc288e79e96a5b158d4875fa6425ad51c85f4c4c8523c1defb9366ad12')
+sha256sums=('c4f2a45687fd39dbde509635ebf094d7ed301793920f37bcaabb8161ff69f2fd')
build() {
cd "${pkgname}-${pkgver}"