summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBumsik Kim2019-12-12 01:54:09 +0900
committerBumsik Kim2019-12-12 01:54:09 +0900
commit0f431d57d9f72fa9adbddc130565481c097cbc3f (patch)
tree4690150bdd007887c9601bf238f84a6d58759a94
parent69df9834be5daf74bf411c368740e2351d3427a5 (diff)
downloadaur-0f431d57d9f72fa9adbddc130565481c097cbc3f.tar.gz
Update: v0.9.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD8
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 293724e60a85..0bee7fb73b38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = uftrace
pkgdesc = Tool to trace and analyze execution of a program written in C/C++
- pkgver = 0.9
+ pkgver = 0.9.3
pkgrel = 1
url = https://github.com/namhyung/uftrace
arch = armv6h
@@ -8,9 +8,16 @@ pkgbase = uftrace
arch = aarch64
arch = x86_64
license = GPL2
+ makedepends = pandoc
+ depends = libelf
+ depends = python2
+ depends = ncurses
+ depends = pkgconf
+ depends = luajit
+ depends = capstone
options = !emptydirs
- source = git+https://github.com/namhyung/uftrace.git#tag=v0.9
- md5sums = SKIP
+ source = git+https://github.com/namhyung/uftrace.git#tag=v0.9.3
+ sha256sums = SKIP
pkgname = uftrace
diff --git a/PKGBUILD b/PKGBUILD
index 9786ce36836d..cc69680ad470 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: YOUNG HO CHA <ganadist@gmail.com>
pkgname=uftrace
-pkgver=0.9
+pkgver=0.9.3
pkgrel=1
pkgdesc="Tool to trace and analyze execution of a program written in C/C++"
arch=(armv6h armv7h aarch64 x86_64)
url="https://github.com/namhyung/uftrace"
license=('GPL2')
groups=()
-depends=()
-makedepends=()
+depends=(libelf python2 ncurses pkgconf luajit capstone)
+makedepends=(pandoc)
optdepends=()
provides=()
conflicts=()
@@ -19,7 +19,7 @@ install=
changelog=
source=("git+https://github.com/namhyung/$pkgname.git#tag=v$pkgver")
noextract=()
-md5sums=('SKIP') #autofill using updpkgsums
+sha256sums=('SKIP')
build() {
mkdir -p "$pkgname"/build