summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-05-03 14:45:44 +0800
committerChocobo12018-05-03 15:27:42 +0800
commiteec7044f9963094bb5532a2c6e7dcf9244acb81e (patch)
tree3828109855ec55865b4bff7ae880d72034eeff0a
downloadaur-eec7044f9963094bb5532a2c6e7dcf9244acb81e.tar.gz
newpkg: ufw-git r1620.gcbfd469-1
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD55
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ea549fb0d0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = ufw-git
+ pkgdesc = Uncomplicated firewall
+ pkgver = r1620.gcbfd469
+ pkgrel = 1
+ url = https://launchpad.net/ufw
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = iptables
+ provides = ufw
+ conflicts = ufw
+ backup = etc/default/ufw
+ backup = etc/ufw/after.rules
+ backup = etc/ufw/after6.rules
+ backup = etc/ufw/before.rules
+ backup = etc/ufw/before6.rules
+ backup = etc/ufw/sysctl.conf
+ backup = etc/ufw/ufw.conf
+ backup = etc/ufw/user.rules
+ backup = etc/ufw/user.rules
+ backup = etc/ufw/user6.rules
+ source = git+https://git.launchpad.net/ufw
+ source = ufw.service::https://git.archlinux.org/svntogit/community.git/plain/trunk/service?h=packages/ufw
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ufw-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e359ba641203
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=ufw-git
+pkgver=r1620.gcbfd469
+pkgrel=1
+pkgdesc="Uncomplicated firewall"
+arch=('any')
+url="https://launchpad.net/ufw"
+license=('GPL3')
+depends=('python' 'iptables')
+makedepends=('git')
+provides=('ufw')
+conflicts=('ufw')
+backup=('etc/default/ufw'
+ 'etc/ufw/after.rules'
+ 'etc/ufw/after6.rules'
+ 'etc/ufw/before.rules'
+ 'etc/ufw/before6.rules'
+ 'etc/ufw/sysctl.conf'
+ 'etc/ufw/ufw.conf'
+ 'etc/ufw/user.rules'
+ 'etc/ufw/user.rules'
+ 'etc/ufw/user6.rules')
+source=("git+https://git.launchpad.net/ufw"
+ "ufw.service::https://git.archlinux.org/svntogit/community.git/plain/trunk/service?h=packages/ufw")
+sha256sums=('SKIP'
+ 'SKIP')
+
+
+prepare() {
+ cd "ufw"
+
+ # FS#28769 - move from /lib to /usr/lib
+ sed -i -e 's|/lib|/usr/lib|' \
+ -e 's|sbin|bin|g' setup.py
+
+ # FS#35458, FS#54110 - correct iptables location
+ sed -i -e 's|sbin|bin|g' setup.py
+ sed -i -e 's|sbin|bin|g' src/util.py
+}
+
+pkgver() {
+ cd "ufw"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+package() {
+ cd "ufw"
+
+ python setup.py install --root="$pkgdir"
+ install -Dm644 "$srcdir/ufw.service" "$pkgdir/usr/lib/systemd/system/ufw.service"
+}