summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2018-01-11 10:44:55 +0100
committerJens Staal2018-01-11 10:44:55 +0100
commit804e23b5f4f9f6d0a2b01a5b2ad1e2ac511e4791 (patch)
tree0395a9b802536a4ed73ab8cb4b37a5c507f21652
downloadaur-804e23b5f4f9f6d0a2b01a5b2ad1e2ac511e4791.tar.gz
fist commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72bb763ac766
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ugene-bin
+ pkgdesc = A free cross-platform genome analysis suite (binary release)
+ pkgver = 1.29.0
+ pkgrel = 1
+ url = http://ugene.net
+ arch = x86_64
+ license = GPL
+ depends = qt5-script
+ depends = qt5-svg
+ depends = qt5-webkit
+ depends = glu
+ depends = procps-ng
+ depends = python
+ provides = ugene
+ conflicts = ugene
+ source = http://ugene.unipro.ru/downloads/ugene-1.29.0-x86-64.tar.gz
+ sha256sums = 524b79d7ae4037eefea19a7db7654f14cf2bb43ba1787fcd854f200e86e633b6
+
+pkgname = ugene-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d59af4dc42b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer Jens Staal <staal1978@gmail.com>
+
+pkgname=ugene-bin
+pkgver=1.29.0
+pkgrel=1
+pkgdesc="A free cross-platform genome analysis suite (binary release)"
+arch=('x86_64')
+url="http://ugene.net"
+license=('GPL')
+depends=('qt5-script' 'qt5-svg' 'qt5-webkit' 'glu' 'procps-ng' 'python')
+provides=('ugene')
+conflicts=('ugene')
+source=("http://ugene.unipro.ru/downloads/ugene-$pkgver-x86-64.tar.gz")
+sha256sums=('524b79d7ae4037eefea19a7db7654f14cf2bb43ba1787fcd854f200e86e633b6')
+
+package() {
+ cd "$srcdir/ugene-$pkgver"
+
+ mkdir -p "${pkgdir}/usr/"{bin,lib/ugene,share/{applications,icons,licenses,man,ugene,mime,pixmaps}}
+
+ #move stuff to the correct locations
+ mv ugene.desktop $pkgdir/usr/share/applications
+ mv LICENSE $pkgdir/usr/share/licenses/ugene
+ mv man1 $pkgdir/usr/share/man/man1
+ mv application-x-ugene.xml $pkgdir/usr/share/mime/
+ mv ugene.png $pkgdir/usr/share/pixmaps/
+ tar -xf icons.tar.gz -C $pkgdir/usr/share/icons
+
+ mv * $pkgdir/usr/lib/ugene/
+
+ cd $pkgdir/usr/bin
+ ln -s /usr/lib/ugene/ugene ugene
+
+}
+