summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-10-11 13:53:14 +0800
committerlilac2021-10-11 13:53:14 +0800
commitfbbbafef169ae02dd1e0eddd0f168c3e28edd008 (patch)
tree4e00ac559c19a5f66fe1dda646cdb027833f4b53
parent5422540c346ebc87094d3dce48e8377c9e58ba82 (diff)
downloadaur-uget-integrator-browsers.tar.gz
[lilac] updated to 1.0.0-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6f74bc6a99b..57da03a1f556 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = uget-integrator-browsers
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/ugetdm/uget-integrator
arch = any
license = GPL3
@@ -31,3 +31,7 @@ pkgname = uget-integrator-firefox
install = firefox.install
optdepends = firefox: the browser
+pkgname = uget-integrator-libreworlf
+ pkgdesc = Configuration to connect LibreWolf with uget-integrator
+ install = firefox.install
+ optdepends = librewolf: the browser
diff --git a/PKGBUILD b/PKGBUILD
index afb832dbfa5d..7720ec93e834 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
#Maintainer : Sasasu <lizhaolong0123@gmail.com>
pkgbase=uget-integrator-browsers
-pkgname=(uget-integrator-chrome uget-integrator-chromium uget-integrator-opera uget-integrator-firefox)
+pkgname=(uget-integrator-chrome uget-integrator-chromium uget-integrator-opera uget-integrator-firefox uget-integrator-libreworlf)
arch=('any')
url="https://github.com/ugetdm/uget-integrator"
license=('GPL3')
depends=('uget-integrator')
pkgver=1.0.0
-pkgrel=2
+pkgrel=4
makedepends=()
source=("ugetdm-chrome-$pkgver::https://raw.githubusercontent.com/ugetdm/uget-integrator/v$pkgver/conf/com.ugetdm.chrome.json"
"ugetdm-firefox-$pkgver::https://raw.githubusercontent.com/ugetdm/uget-integrator/v$pkgver/conf/com.ugetdm.firefox.json")
@@ -56,3 +56,13 @@ package_uget-integrator-firefox(){
mkdir -p "$pkgdir/usr/lib/mozilla/native-messaging-hosts"
install -m644 "ugetdm-firefox-$pkgver" "$pkgdir"/usr/lib/mozilla/native-messaging-hosts/com.ugetdm.firefox.json
}
+
+#for LibreWolf, thanks quentin
+package_uget-integrator-libreworlf(){
+ optdepends=('librewolf: the browser')
+ pkgdesc="Configuration to connect LibreWolf with uget-integrator"
+ install="firefox.install"
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/lib/librewolf/native-messaging-hosts"
+ install -m644 "ugetdm-firefox-$pkgver" "$pkgdir"/usr/lib/librewolf/native-messaging-hosts/com.ugetdm.firefox.json
+}