summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2018-08-31 00:32:53 -0400
committerAdam Goldsmith2018-08-31 00:32:53 -0400
commit14f73cb67f0cde616fd51e7b91b178bc87adfec8 (patch)
tree8997d2a678321af4e1fad262759eb130c109963f
downloadaur-14f73cb67f0cde616fd51e7b91b178bc87adfec8.tar.gz
Initial Commit, 1.2.8
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--uhk-agent-appimage.install4
-rw-r--r--uhk-agent.desktop.patch11
-rw-r--r--uhk-agent.sh2
6 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65fb8d9997e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = uhk-agent-appimage
+ pkgdesc = The configuration application of the Ultimate Hacking Keyboard.
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = https://github.com/UltimateHackingKeyboard/agent
+ install = uhk-agent-appimage.install
+ arch = x86_64
+ license = GPL3
+ depends = libusb
+ options = !strip
+ source = https://github.com/UltimateHackingKeyboard/agent/releases/download/v1.2.8/UHK.Agent-1.2.8-linux-x86_64.AppImage
+ source = uhk-agent.desktop.patch
+ source = uhk-agent.sh
+ md5sums = d39eb1d2d22e7757d9358af898819767
+ md5sums = 6d46d385f3c70dab72e1eea2bee58732
+ md5sums = a417373306c108ea2632571d8309df9b
+
+pkgname = uhk-agent-appimage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc5bef19a2ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.AppImage
+/pkg/
+/src/
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58594266e554
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=uhk-agent-appimage
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="The configuration application of the Ultimate Hacking Keyboard."
+arch=('x86_64')
+url="https://github.com/UltimateHackingKeyboard/agent"
+license=('GPL3')
+depends=(libusb)
+source=("https://github.com/UltimateHackingKeyboard/agent/releases/download/v${pkgver}/UHK.Agent-${pkgver}-linux-x86_64.AppImage"
+ uhk-agent.desktop.patch
+ uhk-agent.sh)
+md5sums=('d39eb1d2d22e7757d9358af898819767'
+ '6d46d385f3c70dab72e1eea2bee58732'
+ 'a417373306c108ea2632571d8309df9b')
+options=(!strip)
+install=${pkgname}.install
+_filename=./UHK.Agent-${pkgver}-linux-x86_64.AppImage
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x ${_filename}
+ ${_filename} --appimage-extract
+ patch -Np0 < ../uhk-agent.desktop.patch
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/opt/appimages/UHK.Agent.AppImage"
+ install -Dm755 "${srcdir}/uhk-agent.sh" "${pkgdir}/usr/bin/uhk-agent"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -r --no-preserve=mode,ownership "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ install -Dm644 "${srcdir}/squashfs-root/uhk-agent.desktop" "${pkgdir}/usr/share/applications/uhk-agent.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/app/resources/rules/50-uhk60.rules" "${pkgdir}/etc/udev/rules.d/50-uhk60.rules"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/uhk-agent-appimage.install b/uhk-agent-appimage.install
new file mode 100644
index 000000000000..12dc22d15464
--- /dev/null
+++ b/uhk-agent-appimage.install
@@ -0,0 +1,4 @@
+post_install() {
+ udevadm trigger
+ udevadm settle
+}
diff --git a/uhk-agent.desktop.patch b/uhk-agent.desktop.patch
new file mode 100644
index 000000000000..adcc28f53b4e
--- /dev/null
+++ b/uhk-agent.desktop.patch
@@ -0,0 +1,11 @@
+--- squashfs-root/uhk-agent.desktop
++++ squashfs-root/uhk-agent.desktop
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Name=UHK Agent
+ Comment=Agent is the configuration application of the Ultimate Hacking Keyboard.
+-Exec=AppRun
++Exec=/usr/bin/uhk-agent
+ Terminal=false
+ Type=Application
+ Icon=uhk-agent
diff --git a/uhk-agent.sh b/uhk-agent.sh
new file mode 100644
index 000000000000..ba397256aa06
--- /dev/null
+++ b/uhk-agent.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+DESKTOPINTEGRATION=no /opt/appimages/UHK.Agent.AppImage