summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 08:52:25 +0000
committerAntonio Rojas2021-05-08 08:52:25 +0000
commit04305d5223087cb04aa512638ef97374f411d75a (patch)
tree6f8fafc881ff827ba323541412301a541a1668d1
downloadaur-04305d5223087cb04aa512638ef97374f411d75a.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD41
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..821e87a53488
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = uim
+ pkgdesc = Multilingual input method library
+ pkgver = 1.8.8
+ pkgrel = 5
+ url = https://github.com/uim/uim
+ arch = x86_64
+ license = custom:BSD
+ makedepends = intltool
+ makedepends = gettext
+ makedepends = gtk2
+ makedepends = gtk3
+ makedepends = qt5-x11extras
+ makedepends = anthy
+ makedepends = skk-jisyo
+ depends = libxft
+ depends = libedit
+ depends = m17n-lib
+ optdepends = qt5-x11extras: immodule and helper applications
+ optdepends = gtk2: immodule and helper applications
+ optdepends = gtk3: immodule and helper applications
+ optdepends = skk-jisyo: input method
+ optdepends = anthy: input method
+ source = https://github.com/uim/uim/releases/download/1.8.8/uim-1.8.8.tar.bz2
+ sha256sums = 34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc
+
+pkgname = uim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..167eff05149e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=uim
+pkgver=1.8.8
+pkgrel=5
+pkgdesc='Multilingual input method library'
+url='https://github.com/uim/uim'
+license=('custom:BSD')
+arch=('x86_64')
+depends=('libxft' 'libedit' 'm17n-lib')
+makedepends=('intltool' 'gettext' 'gtk2' 'gtk3' 'qt5-x11extras' 'anthy' 'skk-jisyo')
+optdepends=('qt5-x11extras: immodule and helper applications'
+ 'gtk2: immodule and helper applications'
+ 'gtk3: immodule and helper applications'
+ 'skk-jisyo: input method'
+ 'anthy: input method')
+source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/uim \
+ --with-qt5-immodule \
+ --with-qt5 \
+ --with-anthy-utf8 \
+ --with-skk \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install -j1 # FS#41112
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}