summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-10-22 23:41:53 +0200
committerCarl Smedstad2023-10-23 00:11:39 +0200
commit5e8b38da87755d31fae351e3712066d3d61ae2ae (patch)
tree94c3fc62c248d4593f6af3137f6e6ab6c08ec898
parent04305d5223087cb04aa512638ef97374f411d75a (diff)
downloadaur-5e8b38da87755d31fae351e3712066d3d61ae2ae.tar.gz
Publish version 1.8.9-1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD80
3 files changed, 66 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 821e87a53488..d3474d9d2df8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
pkgbase = uim
pkgdesc = Multilingual input method library
- pkgver = 1.8.8
- pkgrel = 5
+ pkgver = 1.8.9
+ pkgrel = 1
url = https://github.com/uim/uim
arch = x86_64
license = custom:BSD
- makedepends = intltool
+ makedepends = anthy
+ makedepends = extra-cmake-modules
makedepends = gettext
makedepends = gtk2
makedepends = gtk3
+ makedepends = intltool
+ makedepends = plasma-framework5
makedepends = qt5-x11extras
- makedepends = anthy
makedepends = skk-jisyo
- depends = libxft
depends = libedit
+ depends = libxft
depends = m17n-lib
- optdepends = qt5-x11extras: immodule and helper applications
+ optdepends = anthy: input method
optdepends = gtk2: immodule and helper applications
optdepends = gtk3: immodule and helper applications
+ optdepends = qt5-declarative: immodule and helper applications
+ optdepends = qt5-x11extras: immodule and helper applications
optdepends = skk-jisyo: input method
- optdepends = anthy: input method
- source = https://github.com/uim/uim/releases/download/1.8.8/uim-1.8.8.tar.bz2
- sha256sums = 34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc
+ source = https://github.com/uim/uim/releases/download/1.8.9/uim-1.8.9.tar.gz
+ sha256sums = f442eed7fe58c69eaca1b92a9087e46474b71fd209e2c77c25b0643356067380
pkgname = uim
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 167eff05149e..1025720a9bf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,61 @@
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: damir <damir@archlinux.org>
pkgname=uim
-pkgver=1.8.8
-pkgrel=5
-pkgdesc='Multilingual input method library'
-url='https://github.com/uim/uim'
-license=('custom:BSD')
-arch=('x86_64')
-depends=('libxft' 'libedit' 'm17n-lib')
-makedepends=('intltool' 'gettext' 'gtk2' 'gtk3' 'qt5-x11extras' 'anthy' 'skk-jisyo')
-optdepends=('qt5-x11extras: immodule and helper applications'
- 'gtk2: immodule and helper applications'
- 'gtk3: immodule and helper applications'
- 'skk-jisyo: input method'
- 'anthy: input method')
-source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc')
+pkgver=1.8.9
+pkgrel=1
+pkgdesc="Multilingual input method library"
+url="https://github.com/uim/uim"
+license=(custom:BSD)
+arch=(x86_64)
+depends=(
+ libedit
+ libxft
+ m17n-lib
+)
+makedepends=(
+ anthy
+ extra-cmake-modules
+ gettext
+ gtk2
+ gtk3
+ intltool
+ plasma-framework5
+ qt5-x11extras
+ skk-jisyo
+)
+optdepends=(
+ 'anthy: input method'
+ 'gtk2: immodule and helper applications'
+ 'gtk3: immodule and helper applications'
+ 'qt5-declarative: immodule and helper applications'
+ 'qt5-x11extras: immodule and helper applications'
+ 'skk-jisyo: input method'
+)
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+source=("$url/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('f442eed7fe58c69eaca1b92a9087e46474b71fd209e2c77c25b0643356067380')
+
+_archive="$pkgname-$pkgver"
- CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+build() {
+ cd "$_archive"
- ./configure \
- --prefix=/usr \
- --libexecdir=/usr/lib/uim \
- --with-qt5-immodule \
- --with-qt5 \
- --with-anthy-utf8 \
- --with-skk \
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/uim \
+ --with-qt5-immodule \
+ --with-qt5 \
+ --with-anthy-utf8 \
+ --with-skk
- make
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install -j1 # FS#41112
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ cd "$_archive"
+
+ make DESTDIR="$pkgdir" install -j1
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" COPYING
}