summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorponsfoot2017-03-15 17:45:32 +0900
committerponsfoot2017-03-15 17:45:32 +0900
commit204269740f21d4b11e763f625c8f7f873d065c01 (patch)
tree8926a2b2804db3a84f531c6fd59dedb0855d2ff4
parent247f30fb46cd70fc078c973bceb66728278dfc13 (diff)
downloadaur-204269740f21d4b11e763f625c8f7f873d065c01.tar.gz
Fix source url and build error
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 431f16d11a5f..9af0ee3b4776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=uim-debian
pkgver=1.8.6+gh20161003.0.d63dadd
-_debrel=1
-pkgrel=1
+_debrel=2
+pkgrel=2
pkgdesc='Multilingual input method library with Debian patches (supports gtk3 and qt5)'
url='https://packages.debian.org/sid/uim'
license=('custom:BSD')
@@ -21,8 +21,8 @@ provides=('uim')
install=${pkgname}.install
source=("http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}.orig.tar.gz"
"http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}-${_debrel}.debian.tar.xz")
-sha1sums=('587db7adb61416ff9fe03a06112ff84ca3d76fde'
- 'f5af71424dedecf32366918ee529754c3e5770ce')
+sha256sums=('7a2d1667553afc0bca4cc33f9bc8fb01a6867177d2a3e13b1b85c7add16110e9'
+ '322d1ba023e6d2697c8c2410d6c0e0f1713be47ac08b60d5fdf289307eabbe70')
prepare() {
cd "${srcdir}/uim-${pkgver}"
@@ -42,6 +42,9 @@ prepare() {
done < "${srcdir}/debian/patches/series"
+ sed -i.bak 's/load(qt_plugin)/TEMPLATE = lib\nCONFIG += plugin/' \
+ "${srcdir}/uim-${pkgver}/qt5/immodule/quimplatforminputcontextplugin.pro.in"
+
msg "prepare() done."
}
@@ -60,7 +63,7 @@ build() {
--with-qt4 \
--with-qt4-immodule \
--with-qt5 \
- --with-qt5-immodule \
+ --with-qt5-immodule
make
}