summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorponsfoot2017-10-03 19:48:01 +0900
committerponsfoot2017-10-03 19:48:01 +0900
commit7894918ecb46b75b190bb1af64750243828c710e (patch)
tree2f0b9c43f728d7030f99e26ad4b299cf0a487618
parent0a224f90173bea4d934a80bf7ff51f1fbe146dd4 (diff)
downloadaur-7894918ecb46b75b190bb1af64750243828c710e.tar.gz
Upstream update: 1.8.6+gh20161003.0.d63dadd-5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--qt5-qt4-coexist.patch17
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0ab8a9c2cd7..88c4b0e25b80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# 木 8月 17 01:08:40 UTC 2017
+# 火 10月 3 10:48:01 UTC 2017
pkgbase = uim-debian
pkgdesc = Multilingual input method library with Debian patches (supports gtk3 and qt5)
pkgver = 1.8.6+gh20161003.0.d63dadd
- pkgrel = 4
+ pkgrel = 5
url = https://packages.debian.org/sid/uim
install = uim-debian.install
arch = i686
@@ -27,9 +27,11 @@ pkgbase = uim-debian
provides = uim
conflicts = uim
source = http://http.debian.net/debian/pool/main/u/uim/uim_1.8.6+gh20161003.0.d63dadd.orig.tar.gz
- source = http://http.debian.net/debian/pool/main/u/uim/uim_1.8.6+gh20161003.0.d63dadd-4.debian.tar.xz
+ source = http://http.debian.net/debian/pool/main/u/uim/uim_1.8.6+gh20161003.0.d63dadd-5.debian.tar.xz
+ source = qt5-qt4-coexist.patch
sha256sums = 7a2d1667553afc0bca4cc33f9bc8fb01a6867177d2a3e13b1b85c7add16110e9
- sha256sums = dc72a2d995a8334ff7ca2e9494c463dd5ecf8be76be21ce2ad39cdd2d0e172ec
+ sha256sums = 724b62430f789e5ed0d6dfaaedd8611798c7ff1ad4609717dd1c8bc61d9ba771
+ sha256sums = a3511837b8fc827e3ff79defff6480fc6b3a4ac031bde478bfd5d6c1b77acfdd
pkgname = uim-debian
diff --git a/PKGBUILD b/PKGBUILD
index 650ed84b6561..99dc29199b79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=uim-debian
pkgver=1.8.6+gh20161003.0.d63dadd
-_debrel=4
-pkgrel=4
+_debrel=5
+pkgrel=5
pkgdesc='Multilingual input method library with Debian patches (supports gtk3 and qt5)'
url='https://packages.debian.org/sid/uim'
license=('custom:BSD')
@@ -20,9 +20,11 @@ conflicts=('uim')
provides=('uim')
install=${pkgname}.install
source=("http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}.orig.tar.gz"
- "http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}-${_debrel}.debian.tar.xz")
+ "http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}-${_debrel}.debian.tar.xz"
+ qt5-qt4-coexist.patch)
sha256sums=('7a2d1667553afc0bca4cc33f9bc8fb01a6867177d2a3e13b1b85c7add16110e9'
- 'dc72a2d995a8334ff7ca2e9494c463dd5ecf8be76be21ce2ad39cdd2d0e172ec')
+ '724b62430f789e5ed0d6dfaaedd8611798c7ff1ad4609717dd1c8bc61d9ba771'
+ 'a3511837b8fc827e3ff79defff6480fc6b3a4ac031bde478bfd5d6c1b77acfdd')
prepare() {
cd "${srcdir}/uim-${pkgver}"
@@ -33,6 +35,8 @@ prepare() {
done < "${srcdir}/debian/patches/series"
+ patch -p1 -i "${srcdir}/qt5-qt4-coexist.patch"
+
}
build() {
diff --git a/qt5-qt4-coexist.patch b/qt5-qt4-coexist.patch
new file mode 100644
index 000000000000..2a352c6745af
--- /dev/null
+++ b/qt5-qt4-coexist.patch
@@ -0,0 +1,17 @@
+Description: fix CMake Error not found QT_QT_INCLUDE_DIR when specify both --with-qt4 and --with-qt5.
+Author: HIGUCHI Daisuke (VDR dai) <dai@debian.org>
+Forwarded: https://github.com/uim/uim/pull/62
+Last-Update: 2015-07-22
+
+diff --git a/qt4/toolbar/CMakeLists.txt b/qt4/toolbar/CMakeLists.txt
+index 4601afb..45bc23c 100644
+--- a/qt4/toolbar/CMakeLists.txt
++++ b/qt4/toolbar/CMakeLists.txt
+@@ -1,6 +1,7 @@
+ project(plasma-uim)
+ set(CMAKE_VERBOSE_MAKEFILE on)
+
++find_package(Qt4)
+ find_package(KDE4 REQUIRED)
+ include(KDE4Defaults)
+