summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorponsfoot2016-09-20 14:33:39 +0900
committerponsfoot2016-09-20 14:33:39 +0900
commitd55f27a2487df760da3536ebae76cdb0e78c2961 (patch)
tree3cbb256616fb3cd568aee17a2602f9dae7f08c33
downloadaur-d55f27a2487df760da3536ebae76cdb0e78c2961.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD73
-rw-r--r--uim-debian.install11
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f04090d9f3ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# 火 9月 20 05:33:39 UTC 2016
+pkgbase = uim-debian
+ pkgdesc = Multilingual input method library with Debian patches (supports gtk3 and qt5)
+ pkgver = 1.8.6+gh20160630.0.c408e95
+ pkgrel = 1
+ url = https://packages.debian.org/sid/uim
+ install = uim-debian.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = intltool
+ makedepends = gettext
+ makedepends = gtk2
+ makedepends = gtk3
+ makedepends = qt4
+ makedepends = qt5-base
+ makedepends = qt5-x11extras
+ makedepends = anthy
+ depends = libxft
+ depends = libedit
+ depends = m17n-lib
+ optdepends = qt4: immodule and helper applications
+ optdepends = qt5-base: immodule and helper applications
+ optdepends = gtk2: immodule and helper applications
+ optdepends = gtk3: immodule and helper applications
+ provides = uim
+ conflicts = uim
+ source = http://http.debian.net/debian/pool/main/u/uim/uim_1.8.6+gh20160630.0.c408e95.orig.tar.gz
+ source = http://http.debian.net/debian/pool/main/u/uim/uim_1.8.6+gh20160630.0.c408e95-1.debian.tar.xz
+ sha1sums = ef6b319dedf921f410cfc39ea6912dc79dddf79b
+ sha1sums = 96b3f4bc5a18220744b4489d2c2a3dd3fde40091
+
+pkgname = uim-debian
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d51400d4514
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# $Id: PKGBUILD 270895 2016-07-03 16:55:41Z bisson $
+# Maintainer: ponsfoot <cabezon dot hashimoto at gmail dot com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=uim-debian
+pkgver=1.8.6+gh20160630.0.c408e95
+_debrel=1
+pkgrel=1
+pkgdesc='Multilingual input method library with Debian patches (supports gtk3 and qt5)'
+url='https://packages.debian.org/sid/uim'
+license=('custom:BSD')
+arch=('i686' 'x86_64')
+depends=('libxft' 'libedit' 'm17n-lib')
+makedepends=('intltool' 'gettext' 'gtk2' 'gtk3' 'qt4' 'qt5-base' 'qt5-x11extras' 'anthy')
+optdepends=('qt4: immodule and helper applications'
+ 'qt5-base: immodule and helper applications'
+ 'gtk2: immodule and helper applications'
+ 'gtk3: immodule and helper applications')
+conflicts=('uim')
+provides=('uim')
+install=${pkgname}.install
+source=("http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}.orig.tar.gz"
+ "http://http.debian.net/debian/pool/main/u/uim/uim_${pkgver}-${_debrel}.debian.tar.xz")
+sha1sums=('ef6b319dedf921f410cfc39ea6912dc79dddf79b'
+ '96b3f4bc5a18220744b4489d2c2a3dd3fde40091')
+
+prepare() {
+ cd "${srcdir}/uim-${pkgver}"
+
+ while read p; do
+
+ if [[ "$p" == "qt5-immodule-qmake-conf.patch" ]]; then
+ ispushed="yes"
+ pushd qt5/immodule/
+ else
+ ispushed="no"
+ fi
+
+ patch -p1 -i "${srcdir}/debian/patches/${p}"
+
+ [[ "$ispushed" == "yes" ]] && popd
+
+ done < "${srcdir}/debian/patches/series"
+
+ msg "prepare() done."
+}
+
+build() {
+ cd "${srcdir}/uim-${pkgver}"
+
+ export QT_SELECT=qt5
+
+ ./configure \
+ --disable-rpath \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/uim \
+ --with-anthy-utf8 \
+ --with-gtk \
+ --with-gtk3 \
+ --with-qt4 \
+ --with-qt4-immodule \
+ --with-qt5 \
+ --with-qt5-immodule \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/uim-${pkgver}"
+ make DESTDIR="${pkgdir}" install -j1 # FS#41112
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/uim-debian.install b/uim-debian.install
new file mode 100644
index 000000000000..3a47afa5cf1e
--- /dev/null
+++ b/uim-debian.install
@@ -0,0 +1,11 @@
+post_install() {
+ if [[ -f /usr/lib/uim/plugin/libuim-mozc.so ]]; then
+ echo -n "Registering mozc on uim..."
+ /usr/bin/uim-module-manager --register mozc
+ [[ $? != 0 ]] && echo "Failed." || echo "Done."
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+}