summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2020-11-19 10:48:18 +0800
committerShengyu Zhang2020-11-19 10:49:55 +0800
commit4f21fbbcbc837c69326d086b46e2150a38262bb5 (patch)
tree5b60366b24fee8e365066f07dc3a2757522e354a
downloadaur-4f21fbbcbc837c69326d086b46e2150a38262bb5.tar.gz
addpkg: uivonim-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
-rw-r--r--uivonim.sh2
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..999755255bfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Nov 19 02:48:12 UTC 2020
+pkgbase = uivonim-git
+ pkgdesc = Fork of Veonim, a feature-rich cross-platform GUI that leverages the latest Neovim features (floating windows, builtin LSP, Lua) without reliance on VSCode extensions
+ pkgver = v0.26.3.45.g179fe86
+ pkgrel = 1
+ url = https://github.com/smolck/uivonim
+ arch = x86_64
+ license = AGPL
+ makedepends = npm
+ makedepends = git
+ depends = neovim
+ source = git+https://github.com/smolck/uivonim
+ source = uivonim.sh
+ sha256sums = SKIP
+ sha256sums = 8de71b3528e4f40b77d114080a1bb7a2ade4ad73dd6f9799c2cb640d78209af2
+
+pkgname = uivonim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0639580c8bc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Shengyu Zhang <la@archlinuxcn.org>
+
+_pkgname=uivonim
+pkgname=${_pkgname}-git
+pkgver=v0.26.3.45.g179fe86
+pkgrel=1
+pkgdesc="Fork of Veonim, a feature-rich cross-platform GUI that leverages the latest Neovim features (floating windows, builtin LSP, Lua) without reliance on VSCode extensions"
+arch=('x86_64')
+license=('AGPL')
+url="https://github.com/smolck/uivonim"
+makedepends=('npm' 'git')
+depends=('neovim')
+optdepends=()
+source=("git+https://github.com/smolck/${_pkgname}"
+ "${_pkgname}.sh")
+
+sha256sums=('SKIP'
+ '8de71b3528e4f40b77d114080a1bb7a2ade4ad73dd6f9799c2cb640d78209af2')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --tags | sed 's/-/./g'
+}
+
+build() {
+ cd ${_pkgname}
+
+ npm ci
+ npm run build
+}
+
+package() {
+ cd ${_pkgname}
+
+ npm run package
+
+ install -d ${pkgdir}/opt
+ cp -R dist/linux-unpacked "${pkgdir}/opt/${_pkgname}"
+ install -Dm755 ${srcdir}/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+}
diff --git a/uivonim.sh b/uivonim.sh
new file mode 100644
index 000000000000..5079d88f72c3
--- /dev/null
+++ b/uivonim.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec /opt/uivonim/uivonim "$@"