summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShengyu Zhang2021-01-29 13:42:39 +0800
committerShengyu Zhang2021-01-29 13:42:39 +0800
commitd65c084d640acf5dc6d8d749976c3902724b3e64 (patch)
tree096f9eee7a415ac31eb735a96036618f205b1d2b
parent4f21fbbcbc837c69326d086b46e2150a38262bb5 (diff)
downloadaur-d65c084d640acf5dc6d8d749976c3902724b3e64.tar.gz
uivonim-git: add desktop entry
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
-rw-r--r--uivonim.desktop13
3 files changed, 29 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 999755255bfa..e13b57ac3543 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Nov 19 02:48:12 UTC 2020
+# Fri Jan 29 05:42:28 UTC 2021
pkgbase = uivonim-git
- pkgdesc = Fork of Veonim, a feature-rich cross-platform GUI that leverages the latest Neovim features (floating windows, builtin LSP, Lua) without reliance on VSCode extensions
- pkgver = v0.26.3.45.g179fe86
+ pkgdesc = A Neovim GUI designed for programming
+ pkgver = v0.27.0.28.g7188dd7
pkgrel = 1
- url = https://github.com/smolck/uivonim
+ url = https://glitchtron.org/veonim/
arch = x86_64
license = AGPL
makedepends = npm
@@ -12,8 +12,10 @@ pkgbase = uivonim-git
depends = neovim
source = git+https://github.com/smolck/uivonim
source = uivonim.sh
+ source = uivonim.desktop
sha256sums = SKIP
sha256sums = 8de71b3528e4f40b77d114080a1bb7a2ade4ad73dd6f9799c2cb640d78209af2
+ sha256sums = 17ab49bb6e0f74bc11052554cd0a8f341d772a993fe821143b256bad01d55d4f
pkgname = uivonim-git
diff --git a/PKGBUILD b/PKGBUILD
index 0639580c8bc3..2398f3c7ecd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
_pkgname=uivonim
pkgname=${_pkgname}-git
-pkgver=v0.26.3.45.g179fe86
+pkgver=v0.27.0.28.g7188dd7
pkgrel=1
-pkgdesc="Fork of Veonim, a feature-rich cross-platform GUI that leverages the latest Neovim features (floating windows, builtin LSP, Lua) without reliance on VSCode extensions"
+pkgdesc="A Neovim GUI designed for programming"
arch=('x86_64')
license=('AGPL')
-url="https://github.com/smolck/uivonim"
+url="https://glitchtron.org/veonim/"
makedepends=('npm' 'git')
depends=('neovim')
optdepends=()
source=("git+https://github.com/smolck/${_pkgname}"
- "${_pkgname}.sh")
+ "${_pkgname}.sh"
+ "${_pkgname}.desktop")
sha256sums=('SKIP'
- '8de71b3528e4f40b77d114080a1bb7a2ade4ad73dd6f9799c2cb640d78209af2')
+ '8de71b3528e4f40b77d114080a1bb7a2ade4ad73dd6f9799c2cb640d78209af2'
+ '17ab49bb6e0f74bc11052554cd0a8f341d772a993fe821143b256bad01d55d4f')
pkgver() {
cd ${_pkgname}
@@ -24,17 +26,15 @@ pkgver() {
build() {
cd ${_pkgname}
-
- npm ci
- npm run build
+ npm run package
}
package() {
cd ${_pkgname}
- npm run package
-
install -d ${pkgdir}/opt
cp -R dist/linux-unpacked "${pkgdir}/opt/${_pkgname}"
install -Dm755 ${srcdir}/${_pkgname}.sh "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 ${srcdir}/${_pkgname}/art/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${_pkgname}.png"
+ install -Dm644 ${srcdir}/${_pkgname}.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}
diff --git a/uivonim.desktop b/uivonim.desktop
new file mode 100644
index 000000000000..4e1b1e0017cf
--- /dev/null
+++ b/uivonim.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Uivonim
+GenericName=Uivonim Text Editor
+Comment=Veonim is a Neovim GUI designed for programming
+Exec=uivonim %F
+TryExec=uivonim
+Terminal=false
+Type=Application
+MimeType=text/english;text/plain;text/markdown;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;text/x-ruby;text/x-python;
+Icon=uivonim
+Categories=Utility;TextEditor;
+Keywords=Text;Editor;Neovim
+StartupNotify=false