summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Cohen2022-03-12 18:02:45 -0600
committerDavid Cohen2022-03-12 18:22:11 -0600
commit34f3a9fa10c859df005ada2c0aafa6e20988ac31 (patch)
tree7947b49a517992170e63b56aa755d8e639339873
downloadaur-34f3a9fa10c859df005ada2c0aafa6e20988ac31.tar.gz
Initial commit
Signed-off-by: David Cohen <dacohen@pm.me>
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rw-r--r--ukpdate.install15
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4527e8c2c6de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ukpdate-git
+ pkgdesc = UEFI Unified Kernel Image manager tool
+ pkgver = 0.r116.7350200
+ pkgrel = 1
+ url = https://github.com/osimarr/ukpdate
+ install = ukpdate.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash>=4.4
+ depends = systemd
+ depends = binutils
+ depends = sbsigntools
+ provides = ukpdate
+ conflicts = sbupdate
+ conflicts = ukpdate
+ backup = etc/ukpdate.conf
+ source = git+https://github.com/osimarr/ukpdate.git?signed
+ validpgpkeys = 96F281C741F4F2693E96885BF6532C30466E8B3E,
+ validpgpkeys = 9CE1B36F586373C8A5DD89E447EDFD24F02ADC29
+ sha256sums = SKIP
+
+pkgname = ukpdate-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ed957b97cd0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+ukpdate/
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..781ec318dc87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: David Cohen <dacohen@pm.me>
+# Contributor: Andrey Vihrov <andrey.vihrov at gmail.com>
+
+pkgname=ukpdate-git
+pkgver=0.r116.7350200
+pkgrel=1
+pkgdesc="UEFI Unified Kernel Image manager tool"
+arch=('any')
+url="https://github.com/osimarr/ukpdate"
+license=('GPL3')
+install=ukpdate.install
+depends=('bash>=4.4' 'systemd' 'binutils' 'sbsigntools')
+makedepends=('git')
+conflicts=('sbupdate' 'ukpdate')
+provides=('ukpdate')
+backup=('etc/ukpdate.conf')
+source=("git+https://github.com/osimarr/ukpdate.git?signed")
+validpgpkeys=('96F281C741F4F2693E96885BF6532C30466E8B3E',
+ '9CE1B36F586373C8A5DD89E447EDFD24F02ADC29')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ukpdate
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ukpdate
+ make DESTDIR="${pkgdir}" DOCDIR="/usr/share/doc/${pkgname}" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ukpdate.install b/ukpdate.install
new file mode 100644
index 000000000000..75486aa4323d
--- /dev/null
+++ b/ukpdate.install
@@ -0,0 +1,15 @@
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ if (( "$(vercmp "$2" "0.r72.cca1186-1")" <= 0 )); then
+ cat << EOF || return 1
+
+The location of the configuration file has changed. Use
+
+ vimdiff /etc/ukpdate.conf /etc/default/ukpdate.pacsave
+
+or similar to merge the current configuration.
+
+EOF
+ fi
+}