summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-11-27 01:40:44 +0200
committerYurii Kolesnykov2019-11-27 01:44:13 +0200
commitdf587e4917edbba54c6f71c9ad23f1305b11f03a (patch)
tree9bc91f7e043e043dc9c28f2ea0aa4345fd6b5e13
downloadaur-df587e4917edbba54c6f71c9ad23f1305b11f03a.tar.gz
init
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..479e2cb5798c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = uksmd-git
+ pkgdesc = Userspace KSM helper daemon
+ pkgver = 0.0.0.r15.42f4ff8
+ pkgrel = 1
+ url = https://gitlab.com/post-factum/uksmd
+ arch = x86_64
+ license = GPL3
+ depends = procps-ng
+ provides = uksmd
+ conflicts = uksmd
+ source = uksmd-git::git+https://gitlab.com/post-factum/uksmd.git
+ sha256sums = SKIP
+
+pkgname = uksmd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..53b41172e048
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+uksmd-git
+src
+pkg
+*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f691495349d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Contributor: Oleksandr Natalenko <oleksandr@natalenko.name>
+
+pkgname=uksmd-git
+_repouser=post-factum
+_reponame=uksmd
+pkgver=0.0.0.r15.42f4ff8
+pkgrel=1
+pkgdesc="Userspace KSM helper daemon"
+url="https://gitlab.com/post-factum/uksmd"
+license=(GPL3)
+arch=(x86_64)
+depends=(procps-ng)
+source=(${pkgname}::git+https://gitlab.com/post-factum/uksmd.git)
+sha256sums=('SKIP')
+conflicts=("${_reponame}")
+provides=("${_reponame}")
+
+pkgver() {
+ cd "${pkgname}"
+ printf "0.0.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_reponame}"
+
+ make
+}
+
+package() {
+ cd "${_reponame}"
+
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install
+
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "distro/${_reponame}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+} \ No newline at end of file